Community

Keine Antwort in Homekit?

Hallo miteinander

Da ich zukünftig alle (zumindest möglichst viele) Devices über Homekit steuern möchte, versuche ich es mal mit Homee. Habe ja schon einiges gutes darüber gelesen.

Die Einrichtung war, na ja, es ging so (liegt vermutlich an mir ;-)) Der lange Rede kurzer Sinn. Ich habe als erstes mal eine Steckdose (als Luftbefeuchter benamst) eingelesen und diese dann in Homekit aktiviert.

Soweit so gut. es erscheint auch in der Home App, ABER „Das Gerät gibt keine Antwort“.Was mache ich falsch (ist ja mein erster Test) oder was müsst ihr noch wissen?

Danke für allfällige Feedbacks

Kann da leider nichts erfreuliches zu beitragen. Ich habe das Problem auch, schon seit dem Beginn an. Siehe auch die ganzen entsprechen Threads dazu. Für mich ist es leider nicht brauchbar. :frowning:

Welches Gerät genau hast du denn eingebunden ?

Und kannst du es über homee schalten beziehungsweise seinen Zustand abfragen?

Danke für Feedback. JA, ich kann es über Homee schalten. Es handelt sich um einen Osram Plug In. Ich kann ihn über Homee bedienen. Aber, wenn ich die Home App starte kommt immer ein paar Sekunden jeweils „Aktualisieren“ und dann „Keine Antwort“ ?!?!

Welche Geräte hast du sonst noch am Homee?
Und was sagt das Tagebuch ?

Ich hänge mich mal mit “meinem” nicht Antworten hier dran… evtl. bekommt man es ja doch noch etwas eingekreist.

Ich betreibe homee als reines Testsystem. Alle Geräte sind über die FritzBox oder virtuelles HIH über Node-Red eingebunden. Funkwürfel habe ich keine mehr in Betrieb.

Bei mir geht es um eine Osram Kalt/Warmweiß Birne.
Die Birne ist über homee weiterhin ansprechbar und reagiert schnell, also hier keine Probleme.

HomeKit funktioniert nach einem Neustart vom Brain für eine “gewisse” Zeit, ein paar Minuten, manchmal Stunden.

Der Brain hat die Version 2.27.1, das Problem habe ich aber schon zwei Jahre und mit allen Firmware Versionen auf dem Weg hierher.

Der Brain ist per LAN-Adapter angebunden.

Es ist nur ein Gerät über den homee im HomeKit (wie gesagt zum Testen). Alles andere läuft stabil und zuverlässig über homebridge.

Es sind insgesamt 3 iPads, 2 iPhones und eine Watch eingebunden. Eines der iPads fungiert als Zentrale. Alle iOS Geräte sind auf dem aktuellen Stand (gerade iOS/iPad OS 13.3.1 bzw. WatchOS 6.1.2).

Nach welcher Information ich im Tagebuch suchen soll ist mir nicht ganz klar, ich finde aber keine Auffälligkeiten, außer dass das Wetter letzte Nacht nicht aktualisiert werden konnte.

Gruß
Daniel

Wie gesagt, es ist bisher das einzige Gerät (Osram Lightify Plug In) im Homee System. Es geht ja genau darum, zu sehen, was es kann und das ist bisher…
Alles andere läuft stabil (zwischen 40-50 Geräte, das Meiste in Homekit, ganz wenig über Alexa). Und das Tagebuch ist glaub ich auch nicht gerade ergiebig.

Gruss

@Volker könntest du hier mal draufsehen?

Ja wenn das reproduzierbar ist können wir vielleicht etwas finden :+1: Bräuchte dazu einmal den Support-Zugang (wie immer über PN). :wink:

1 Like

Hallo Volker. Meinst du mich mit PN?

Ja unter anderem :smile:

Und @danil :wink:

Nach ca. 6 Stunden (mehr oder weniger ununterbrochenem) Suchen haben @Volker und ich zumindest bei mir den Fehler (hoffentlich) finden können.
Es wird bei solchen Dingen natürlich direkt technisch :slight_smile:

Hintergrund: Homekit-Geräte wie Bridges etc. werden über den Bonjour Service im lokalen Netzwerk gefunden. Siehe dazu auch : https://de.wikipedia.org/wiki/Bonjour_(Apple)

Dies ist im Hintergrund mDNS, also ein Multicast-Protokoll.

Uns war nun aufgefallen, dass der mDNS Eintrag, welchen man mit der iOS App Discover (App) nur die ipv6-Adresse des homee zu sehen war, nicht aber die ipv4-Adresse.

homee - xxxxxxxxxxxx._hap._tcp.local.

homee-xxxxxxxxxxxx.local:55001
2003:d2:xxxx:xxxx:xxxx:xxxx:xxxx:5126:55001

c# = 6
ci = 2
ff = 0
id = 00:05:xx:xx:xx:xx
md = homee - xxxxxxxxxxxx
pv = 1.0
s# = 1
sf = 0
sh = hl9HzQ==

Insgesamt schien der homee aber richtig “angemeldet” zu sein, zeigt jedoch keine Reaktion in der Home-App (Keine Antwort).

Das Tool dns-sd.exe auf meinem Windows-Rechner hat aber zu dem Protokoll _hap._tcp den homee nicht finden können.

Volker hat dann den DNS-Dienst auf dem homee neu gestartet, was dazu geführt hat, dass der homee für genau 36 Sekunden in HomeKit sichtbar war.

dns-sd.exe -B _hap._tcp
Browsing for _hap._tcp
Timestamp     A/R Flags if Domain                    Service Type              Instance Name
18:38:54.721  Add     2  5 local.                    _hap._tcp.                homee - xxxxxxxxxxxx
18:39:30.870  Rmv     0  5 local.                    _hap._tcp.                homee - xxxxxxxxxxxx

Dieses Verhalten war nicht durch homee motiviert, musste also eine andere Ursache haben.

Nach einigen Suchen dann folgende Erkenntnis:
Ich setze einen Netgear GS116Ev2 Switch ein. Ist ist ein Switch, welcher das sogenannte IGMP Snoofing unterstützt. Dies dient dazu, bei Multicast-Streams wie z.B. Telekom Entertain, die Pakete nur an die richtigen Empfänger weiter zu leiten und nicht an alle, wie sonst bei Multicast üblich. Dies hat leider auch dazu geführt, dass die mDNS (auch Multicast-Pakete) vom homee irgendwie verworfen wurden. Das Abschalten der Funktion in meinem Switch hat nun dafür gesorgt, dass das HomeKit bereits seit 1,5 Std. nun funktioniert.
https://kb.netgear.com/31257/Default-IGMP-settings-may-affect-multicast-streams-on-NETGEAR-Web-Managed-Plus-Switches

Warum nun homee-HomeKit damit Probleme hat, homebridge-HomeKit aber nicht, ist ein offenes Rätsel, was gelöst werden will.

Jedenfalls drücke ich mir die Daumen, dass es nun stabil läuft und hoffe, mit dieser Info können auch andere “Keine Antwort” geplagte Anwender endlich HomeKit mit homee genießen.

In diesem Sinne, happy homeeing :smile: und auch an dieser Stelle noch mal vielen Dank für den super geduldigen und ausdauernden Support!

8 Like

Das ist super das Ihr zwei das gefunden habt. @Volker ist bei dem Projekt ja sehr ausdauernd.
Mal sehen ob es auch jemanden für den zwave Bereich gibt.

Grossartig dieser Einatz und das nimmermüde „Aufdecken" von Bugs. DANKE! Ich hoffe bloss, dass ich das als Homee-Rookie hinkriege. Klingt doch alles etwas kompliziert…

Also um ehrlich zu sein. Ich habe keinen blassen Schimmer, wie ich das nun auf meiner Homee Webapp auf dem MacBook umsetzen muss :frowning:

Gruss DrShot

Hallo @DrShot,
also… zumindest in meinem Fall konnte die homee-Webapp nichts ausrichten.
Schritt 1: schau mal bitte mit diesem Tool (habe kein Mac, daher schnell gegooglet) https://apps.apple.com/de/app/discovery-dns-sd-browser/id1381004916?mt=12 nach, ob der homee unter _hap._tcp gelistet ist.

1 Like

Vielen Dank. also, soweit ich das beurteilen kann, ist er das NICHT.![08|348x500]
29

Ok, das würde ich so unterschreiben, der homee fehlt hier.
Wie ist der homee mit deinem Netzwerk verbunden?
Über LAN oder WLAN? Was setzt du für einen Router ein?
Gibt es weitere Netzwerkhardware? Accesspoints, Switches etc. und wie sind diese verbunden?

Also mein Homee Cube ist über WLAN mit meinem Netz verbunden. Der Router ist eine Fritzbox 7590. Also hier mal meine Konfig (falls es was bringt), einfach ohne die Homekit Geräte.

Schau mal hier ob das hilft… nur als Idee.

https://avm.de/service/fritzbox/fritzbox-7272/wissensdatenbank/publication/show/592_Storungen-beim-Fernsehen-uber-IPTV-Anschluss/

Dort geht es zwar um IPTV, aber die Technik ist ja identisch.

Die FritzBox macht auch einiges an Multicast Optimierungen.
Nicht, dass es da auch Probleme gibt.

Wenn du den Brain neu startest, ist denn dann für einen kurzen Moment _hap._tcp in dem Discovery Tool?

1 Like