Nuki Gerät ist immer "Nicht verfügbar"

Vermute auch dass es kein generelles Problem ist.
Aber mangels Fehlermeldung kann ich auch nicht prüfen woran es liegt.

Homee zeigt ja nur an “Gerät nicht verfügbar” aber leider kein Log oder detaillierte Fehlermeldung.

Dein Receiver Plugin ist das ein Enigma Receiver?

Ja eine Dreambox, meine Plugins sollen nur darauf laufen

Ich habe auch eine. Wie haste das hin bekommen?

Verstehe die Frage nicht wirklich :confused:, hab doch geschrieben das ich ein Plugin für die Dreambox geschrieben habe.
Es ist aber noch quick and dirty sozusagen Alpha Status, deshalb habe ich es auch noch nicht public gemacht.

Hallo Jack Daniel,

das wird aber Zeit (Ironie) Super-Arbeit, bitte weitermachen und veröffentlichen.

Danke.

BLRD

Hehe genau an der Zeit fehlt es … :cry:
Aber der Winter ist ja noch lange :wink:

Hi,

ich hatte wegen der Sache mal an Nuki geschrieben (von deren Support ich bisher IMMER begeistert war).

Meine Mail:

Es wäre (gerade für die Fehlersuche im Zusammenspiel mit via der Bridge integrierten Gateways, hier homee) hilfreich, wenn Ihr im Log der App auch Batteriewarnmeldungen anzeigen würdet (selbst wenn diese vom benutzten Algorithmus hinterher wieder revidiert werden – was wohl passieren kann, wie ich gestern selbst erlebt habe).

Wir haben in der homee Community gerade eine Diskussion genau darum – aus irgendwelchen Gründen (wahrscheinlich durchaus berechtigt) nimmt Euer Batteriewarnungs-Algorithmus an, dass die Batterie bald zur Neige gehen könnte und stellt diese Info wie spezifiziert dann an der API der Bridge bereit. Später wird dieser Zustand, dann ggf. wieder revidiert und ist dann nicht mehr in der GUI Eurer App (weder im Log noch in einem Archiv der vergangenen Benachrichtigungen) ersichtlich.

Allerdings nimmt der homee in dem Moment an der API diese Batteriewarnmeldung an und pusht sie (Standardfunktion des homee, sofern nicht bexplizit vom User deaktiviert) als eigene Meldung (Batterie am Gerät X niedrig) an die definierten User. Die sich dann natürlich darüber aufregen, dass homee etwas meldet, was sie in der App dann (ggf. ist der Status dann schon wieder revidiert) nicht (mehr) sehen.

Meine zwei Bitten dazu:

  • Könnt Ihr diesen Verbesserungsvorschlag bitte aufnehmen? (ist nicht-kritisch - aber nice-to-have)
  • Gibt es ein tiefergehendes Log wo das ersichtlich wäre?

Die Antwort:

Unsere Entwickler arbeiten bereits an einer verbesserten Version diesbezüglich. Möglich wäre ein solcher Vorfall zwar trotzdem, da die Batterien sich auch mit der Zeit langsam erholen, es sollte dann jedoch deutlich reduzierter vorkommen.

Hinsichtlich detaillierter Batterieinformationen dürfen wir Dich auf den in der App versteckten Batterieinfoscreen verweisen:
Um den Batteriestand zu überprüfen, gehe bitte in den Admin Bereich in Deiner App und öffne den Menü Punkt “Battery Type”, tippe nun sieben Mal auf das erste Textfeld. Nun findest Du die entsprechenden Werte der Spannung bzw. auch ob der letzte Sperrvorgang als kritisch erfasst wurde.

…der Infoscreen bestätigt meine Vermutung: Bei einem Sperrvorgang sinkt die niedrigste Spannung um 700-800, um sich dann wieder zu recovern.

Bei mir:

  • Vor dem letzten Sperrvorgang 5104
  • Niedrigste Spannung beim letzten Sperrvorgang 4356
  • Aktuell Spannung; 5096
1 Like

WOW - klasse. Super Danke für die Info. :heart_eyes:

Bei mir (habe daraufhin gerade frisch geladene eneloop pro Akkus eingelegt, die Nuki ja empfiehlt)

Vor dem letzten Sperrvorgang 5462
Niedrigste Spannung beim letzten Sperrvorgang 4945
Aktuell Spannung; 5466

mal sehen wie sich das so entwickelt.

Und genau solch ein Support ist spitze :+1:
Wen ich fragen darf, wie lange hast du auf die Antwort gewartet?

2 Tage, 3h :wink:

Hallo zusammen,

ich häng mich hier mal dran. Bei mir war Nuki plötzlich auch auf “Nicht verfügbar”. Genaue Ursache kenne ich nicht (Nuki-Update ?). Egal. Habe es also aus Homee gelöscht und wollte neu implementieren. Dies funktioniert aber absolut nicht. Ich habe es bestimmt schon 30 mal versucht. Über Smartphone, über Homee-Web.
Ich kann alles eingeben, Homee findet auch die Bridge. Wenn ich dann aber auf anlernen gehe dreht sich Initialisieren ewig im Kreis, bzw. im Browser wird ebenso ewig “Hinzufügen” angezeigt. Irgendwann hört dass meist auch mal auf (ohne Fehlermeldung seitens Homee) aber nix da. Kein Nuki bei den Geräten.
Nuki an sich funktioniert soweit problemlos.

Hat da jemand von Euch noch ne Idee ?

@anon97065019 - willst Du Dir das mal ansehen?

Hi Peter!

Ich habe dazu auch an Nuki geschrieben und Ihnen das Log geschickt.
Bei mir war es dass im Nuki der Web CallBack doppelt drin war von homee.

Ich habe dann alle CallBacks in Nuki gelöscht und dann nochmals in homee erneut angelernt und jetzt klappt es soweit.

Mit deiner Nuki IP und deinem Token von Nuki diese URL aufrufen:
http://192.168.1.50:8080/callback/list?token=123456

Dann siehst du alle Callbacks.

Danach dann alle löschen mit der URL und wieder deiner IP und token:
http://192.168.1.50:8080/callback/remove?id=0&token=123456

Details dazu findest du im PDF auf der NUKI Homepage unter "Callbacks:

4 Like

Waren die Einträge von homee identisch oder hat sich die IP von homee geändert?

Gute Frage, das weiß ich leider nicht mehr.
Es waren nur zwei Callbacks drin und ich habe beide gelöscht und dann in homee erneut angelernt und es hat auf Anhieb funktioniert.

Seitdem bleibt auch das Gerät aktiv und funktioniert.

Ich da mal ne Frage zu den Callbacks!

Wieviele müssen da auf gelistet sein ?

bei mir steht id: 0
id: 1

Also wenn du nur “homee” damit verwendest dann sollte da genau einer drin stehen.
Und zwar der mit der homee IP Adresse.

Hi Chris,

Daaaaankeeee… hat funktioniert !

1 Like

Sorry konnte leider nicht ehr anworten.
Vielen dank für die Info.

Aber bei mir steht unter ID 0 und ID1 das selbe. Welchen davon kann ich löschen?

Komisch ich habe ebend noch mal reingeschaut, aber jetzt steht da gar nichts mehr ???

ausser : success: true

Aber es scheint trotzdem alles zu Funktionieren!!!

homee prüft regelmäßig, ob er in der Callback Liste steht und fügt sich von alleine wieder hinzu. Allerdings sollte kein Eintrag doppelt auftauchen.

@Blacky
Befehle an das Schloss senden funktioniert auch ohne den Callback Eintrag. Allerdings werden dann keine Events empfangen (manuelles Aufschließen oder aus der Nuki App).

Das dürfte eher die Antwort auf das Entfernen sein, wurde danach nochmal die Liste abgefragt?