Kein Verlauf

Das ist es wohl. Ich hab neben einem virtuellen homee auch noch gut 80 z-Wave Geräte und einige enocean am laufen. Scheinbar zu viel für den kleinen Würfel

Das ist traurig, aber eine große Wahrscheinlichkeit :expressionless:

Ich habe für die Geräte, bei denen es uninteressant ist, einfach den Verlauf deaktiviert. Das könnte helfen…

3 Like

Das handhabe ich auch schon seit längerer Zeit so. Bei Geräten mit uninteressanten Verläufen und besonders vielen Einträgen habe ich den Verlauf deaktiviert und bei allen wo möglich die übertragenen Daten soweit möglich reduziert. Das Problem scheint ja wieder ein ReadOnly im Dateisystem zu sein.

Backup ist inzwischen eingespielt und aktuell läuft die Datenbank wieder. Hoffe das dies auch in Zukunft so bleibt und nicht in 1h schon wieder nicht mehr funktioniert.

1 Like

Die Frage ist, wie das Problem ausgelöst wird. Ich hatte es vor ungefähr einem Jahr mal…vermute ich, weil genau die gleichen Symptome vorhanden waren und tagelang kein Backup geschrieben wurde seinerzeit. Es half auch nur ein kompletter Reset mit Einspielung eines alten Backups

Ich habe es auch seit einiger Zeit. Verlauf plötzlich leer ohne aktives dazutun. Komischer Weise ab unterschiedlichen Daten bei den Geräten…
Aufgefallen ist es mir zuerst bei nem Zwischenstecker.

Also ich habe keinen homee in homee am Start, keine externen Lösungen wie Node-red o.ä. und aktuell bin ich bei 65 Geräten, die Hälfte davon Enocean. Sollte das schon zu viel sein für den Homee?

Aus meiner Sicht nein!
Wir sprechen hier von einer Smart Home Zentrale und diese sollte mit einigen hundert Sensoren und Aktoren zurecht kommen. In jedem Raum ein paar Steckdosen, Temperatur-, Fenster und Türsensoren. Ein Licht hier, eins da, und natürlich fehlen noch Bewegungsmelder und Präsenzsensoren. Da kommt schnell einiges zusammen und nur im Zusammenspiel aller wird das Ganze Haus smart. Hier muss homee schnellstens nachbessern und die bestehenden Probleme angehen.
Denn ein Smart Home wächst Stück für Stück, leider kommt homee mit dem aktuellen Tempo der Entwicklung nicht hinterher.

2 Like

Customer-Driven Engineering kann man so oder so sehen :wink:

1 Like

Ich habe 145 Geräte und habe solche Probleme zum Glück nicht, also würde ich nicht sagen, dass das zu viel für den homee ist. Ich glaube nicht, das es an der Anzahl der Geräte liegt, sondern ein anderes Problem vorliegt.

3 Like

Meine Frage war auch eher rhetorisch zu verstehen. Ich gehe selbstverständlich davon aus bzw. ich erwarte, dass homee als Smart Home Zentrale mehr Geräte stemmen kann.
Ich habe @Steffen meine Unterstützung angeboten, falls die Analyse von meinem System zur Ursachenfindung beitragen kann.

2 Like

Guten Abend,

generell stimmen ich euch natürlich zu und sollte auch kein Problem sein mit vielen Geräten und dieses Verhalten lässt sich auch nicht auf zu viele Geräte schließen.

Das meiste Phänomen mit dem „Read-Only“ hatte ich bei homee’s mit Node-Red Anbindungen gesehen aber auch bei einigen ohne Externe, was aber auch durch spontane Stromausfälle oder ähnliches.

Warum dieses hier und da Auftritt lässt sich sehr schwer untersuchen, aber dieses eher seltene Problem lässt sich dann auch schnell durch ein Backup lösen.

Bringt aber nichts wenn es kein Backup gibt oder die Geräte an unterschiedlichen Daten den Verlauf kappen.
Ursachenforschung sollte hier schon betrieben werden. So selten scheint es ja nicht zu sein, fällt halt auch nicht immer gleich auf…

1 Like

Bei mir war beim letzten Mal halt auch das Backup über Wochen fehlerhaft und konnte von homee nicht eingelesen werden. Damit waren alle Änderungen bis dahin hinfällig und mussten wieder eingepflegt werden. Wieder einige Stunden unnütze Arbeit. Ist echt ärgerlich wenn dies passiert.

2 Like

Das mag durchaus sein das ein Backup schnell eingespielt ist. Geht halt solange man vor Ort ist. Aus dem Urlaub oder beim homee im Ferienhaus lässt sich das leider nicht einfach mal beheben.

3 Like

Gestern hat wieder ein Gerät von sich aus den summierten Verbrauch zurückgesetzt. Der Support war vorher drauf und sollte dann Würfel abnehmen und wieder aufsetzen, in dem Zeitraum hat sich das Gerät genullt…

Und es ist wieder mal soweit: homee zeichnet keine Verlaufsdaten mehr auf. Mit schöner Regelmäßigkeit taucht das Problem alle 2-3 Monate bei mir auf. @Steffen: wenn du zu Analysezwecken einen Blick auf das System werfen möchtest, gib mir Bescheid, dann sende ich dir einen Support Zugang. Ich befürchte, dass ich den homee mit einem Backup wieder neu aufsetzten muss. Wirklich ärgerlich …

Hilft es denn den Verlauf zu löschen?
Oft ist die Influx DB korrupt und kann erst nach dem erneuten anlegen wieder beschrieben werden.
Sollte dein System jedoch im read only Modus sein muss wirklich der @Support da Hand anlegen.

VG

Beim letzten Mal hat das Löschen des Verlaufs zum Systemabsturz geführt, so dass ich garnicht mehr auf den homee kam. Das System war in der Tat im read-only Modus. Ich vermute daher, dass das auch jetzt so ist.