Community

Rollladen Aktor zeigt nach Bedienung durch HomeKit wieder Lamellenposition an (rc8)


#1

Hallo zusammen,

da scheint sich ein sehr unschöner Bug in die aktuelle Beta eingespielt zu haben.
Core Version: 2.24.0 (aa4d0b9 rc8)
iOS App Version: 2.24 (4455))
Web App Version: 2.24.0 (41cce20) | beta
NodOn Roller Shutter Firmware 1.3.0

Setup: Alle NodOn Roller Shutter Module sind auf den Betriebsmodus “Rollladen” und NICHT wie per Default “Jalousie” gestellt (warum ist der Default eigentlich Jalousie, wenn dies gar nicht unterstützt wird?! anderes Themas…).

Vorgehen:

  1. Per HomeKit (hier home App auf dem Mac) ändere ich die Position der Rolllade bzw. Markise.
  2. Aktion wird ausgeführt
    Ist: Sowohl die iOS App als auch die Web App zeigen nach der Aktion einen zweiten Regler für die Lamellenposition an. Die Einstellungen des Moduls sind weiterhin auf “Rollladen” eingestellt.
    Soll: Wie konfiguriert darf keine Lamellenpositionseinstellung vorhanden sein.

Den Fehler konnte ich reproduzieren. Zur Behebung des Darstellungsfehlers muss der Betriebsmodus erst von (korrekt) Rollladen auf Jalousie und dann wieder auf Rollladen gesetzt werden.

Web App nach der Ausführung der Aktion durch HomeKit:

iOS App (anderer Aktor):

Einstellung “Betriebsmodus” sind korrekt gesetzt:


#2

Weil das Gerät ein bestimmtes EnOcean Profil verwendet, in welchem halt Jalousie als Funktion definiert ist. Das Nodon diese Funktion nicht umgesetzt hat würde, wenn es hier einen Standard gäbe, bedeuten das Gerät würde so nicht Zertifiziert werden. Da es dies aber nicht gibt und praktisch jeder Hersteller machen kann was er möchte ist dies der Umweg. homee dient als Abstraktion zwischen Standards und hat kein Konzept von diesem oder jenem bestimmten Gerät. Daher wird sich unsererseits stets an die Definition im Standard gehalten. Gerätehersteller tun dies in der Regel selten.

Was den andern Fehler angeht kümmern wir uns darum, danke fürs melden :beers:


#3

Neuere /zukünftige nodon - Geräte sollen sich standard - konformer verhalten

Hier ein Interessanter “Dialog”

…we have interviewed Graham MARTIN, CEO of EnOcean Alliance, to understand those two Certifications and their impact on smart building. Moreover, Alexis our R&D Electronics Manager, explains our internal methods of certification


#4

Da fängt das Problem schon an :wink:


#5

Mir gefällt das Today hier … :wink:

Today, with the new Certification Program, we make sure that our own process is similar to the requirements of EnOcean Alliance


#6

Ja voll gut, zumal die meisten EnOcean Geräte keinerlei Softwareversion oder implementierte (oder etwa nicht implementierte) Fähigkeiten nach außen geben und man als Gateway keinerlei Ahnung hat mit welchem Gerät man es eigentlich zu tun hat :man_shrugging:

Von Software Updates möchte ich gar nicht erst sprechen … :man_facepalming:


#7

Hallo,
interessant, dass in diesem Fall die Lamellenposition angezeigt wird, diese jedoch nicht erwünscht ist bzw. nicht eingestellt ist.
Hier bei mir genau anders herum, weder ein Fibaro Roller Shutter noch der von CA mir als die bessere Alternative angebotene Qubino Flush Shutter lassen sich dazu bewegen mal endlich die lamellenposition anzuzeigen!
Leider hilft bei mir auch nicht die Jalousie mit HomeKit zu steuen (tue ich eh ausschließlich) … nach wie vor keine Chance die Lamellenpositionierung in Homee (WebApp oder iOS, egal) mal zu Gesicht zu bekommen.


#8

Hallo @danholt,

das ist in der Tat etwas unglücklich herauszufinden. :wink:

Aus dem Qubino Manual:

Bei der Aktivierung des Jalousie-Modus muss die Positionskalibrierung für Lamellen durchgeführt werden. Danach können Position und Winkel der Lamellen eingestellt werden. Standardmäßig ist die volle Umdrehungszeit für Lamellen auf 1,5s eingestellt. Dieser Wert kann mit Parameter 72 geändert werden.

  1. Die Kalibrierung des Moduls gemäß Abschnitt “Belichtungspositionierung” ein- und ausführen.
  2. Setze den Parameter 71 auf 1 “Jalousien”.
  3. Das Modul exkludieren (ohne Reset!).
  4. Das Modul erneut inkludieren.
  5. Nach der Modulintegration neben dem Haupt-Shutter-Widget wird ein weiteres Widget für die Lammellensteuerung auf Ihrer UI angezeigt.
  6. Standardmäßig ist die volle Umdrehung auf 1,5s eingestellt. Wenn diese Zeit zu lang ist (wenn nach dem Abschneiden des vollen Zyklus der Verschluss nach oben oder nach unten beginnt), verringern Sie diese Zeit, die mit dem Parameter 72 definiert ist. Wenn diese Zeit kurz ist (wenn die Lamellen sich nicht für den vollen Zyklus drehen), erhöhen Sie diese Zeit mit Parameter 72.

Heißt vereinfacht:

  • Betriebsmodus in homee auf Jalousie (mit Positionierung) setzen
  • Gerät auslernen (nicht zurücksetzen und nicht löschen erzwingen)
  • Gerät einlernen

Nun sollte die Lamellenposition angezeigt werden :slight_smile:

LG Volker


#9

Top!
Von “hinten durch’s Knie” funktioniert nun schon mal die Lamellenposition. Intuitiv ist definitiv anders :wink:
Danke!


#10

Das liegt bei dem Gerät leider nicht in unserer Hand. Wende dich hier gern an den Hersteller des Gerätes :wink:


#11

Ja, wir sind eh mit Qubino im Gespräch, da das Teil nicht vernünftig kalibriert starten wir jetzt den 3. Versuch mit dem brandneuen FIBARO Walli Roller Shutter (FGWREU-111), der heute angekommen ist. Angelernt als “anderes Gerät”. Mal schauen, ob es damit gelingt die Jalousie zu positionieren UND die Lamellen einzustellen. Eventuell von Interesse? Ich nehme mal an, das bei Euch noch kein Fibaro Walli Roller Shutter im Einsatz war… vielleicht lässt es sich mit dem Teil endlich realisieren Kalibrierung/Positionierung und Lamellenwinkel exakt zu stellen. :wink:

NACHTRAG:
FIBARO Walli Roller Shutter ließ sich reibungslos anlernen und Kalibrieren, aber wieder (wie beim FIBARO Roller Shutter 3) keine Steuerung der Lamellen möglich :frowning: Der Qubino Flush Shutter bietet zwar die Lamellenposition an, aber die Kalibrierung der Position/Endschalter tut es zum verrecken nicht.