Community

Problem beim Anlernen Winkhaus Fenstersensor in Version 2.26

Hallo zusammen, ich habe bereits seit einiger Zeit diverse Winkhaus Fenstersensoren in Verwendung, die ich als „anderes Gerät“ in homee angelernt habe. Die Zustände offen und geschlossen wurden erkannt, die Batterie Spannung leider nicht. Umso mehr hat mich die offizielle Unterstützung des Sensors in 2.26 gefreut, da dies damit nun auch möglich sein sollte siehe auch hier Als ich heute das Ganze mit einem Sensor testen wollte, hat es aber nicht funktioniert. Habe homee in den Anlernmodus versetzt, aber noch bevor ich überhaupt die Anlerntaste am Sensor drücken konnte, hat homee einen Sensor erkannt. Es ist nicht der Sensor, den ich anlernen wollte, denn auf eine Zustandsänderung an diesem Sensor reagiert homee nicht. Ich habe einen weiteren Test gemacht und die Batterie des Sensors herausgenommen, den Enocean Würfel entfernt und wieder aufgesetzt. Ich hätte erwartet, dass sich der Sensor nun nicht mehr meldet. Aber er meldet sich als verfügbar! Meine Schlussfolgerung: beim Anlernen wurde ein Funktelegramm eines anderen bereits angelernten Sensors aufgenommen, der dann doppelt vorhanden ist (einmal als „anderes Gerät“, einmal als Winkhaus Sensor) @Thomas: kann das sein? Mache ich irgendetwas falsch? Würde mich über Tipps/Hilfe aus der Community freuen.

Hallo :wave:

lösche einfach das “falsch” eingelernte Gerät und versuche den entsprechenden Fensterkontakt erneut anzulernen. Doppelt sollten die Geräte nicht in der Liste auftauchen. homee würde kein Gerät als neues hinzufügen wenn er dessen ID bereits kennt. Daher schätze ich, du wirst in deinem Umfeld nicht der einige EnOcean Nutzer sein und hast zufälligerweise ein anderes Telegramm “aufgeschnappt".

Hallo @Thomas, danke für deine schnelle Antwort. Ich habe es jetzt mehrmals probiert, den Sensor anzulernen. In ca. 75% der Fälle klappt das Anlernen nicht. Es wird irgendein Kontakt erkannt, aber nicht der richtige. Ich habe auch meinen Eltako Repeater einmal ausgeschaltet, um ggf. den Einfluss von Nachbarn zu minimieren (falls diese tatsächlich Enocean Technologie im Einsatz haben). Aber der Einfluss war nicht wirklich messbar. Was mir auffiel: immer wenn ich den falsch eingelernten Sensor gelöscht habe, hat sich einer meiner bereits angelernten Fenstersensoren verabschiedet (permanent nicht verfügbar). Erst nach ab– und aufsetzen des Enocean Würfels war der Sensor wieder da. Vielleicht doch ein Einfluss aus meinem eigenen Enocean Netzwerk? Aber am meisten stört mich, dass der Sensor, wenn er denn erkannt wird, nur den Zustand offen und geschlossen meldet und nicht den Batteriezustand. Das aber sollte doch in 2.26 auch funktionieren, oder? Ich habe nach Anleitung den Anlernknopf max. 2 Sekunden gedrückt, das richtige Funkprotokoll sollte also nach meinem Verständnis aktiv sein. Was kann die Ursache sein?

Du hast bislang noch gar nicht erwähnt, dass du irgendwelche Repeater im Einsatz hast. Dies ist ein wichtiger Punkt.

Repeater sollten am besten alle abgeschaltet sein wenn du Geräte einlernen willst. Dadurch kann es tatsächlich zu immensen, nicht nachzuvollziehenden Problemen kommen.

Korrekt, das funktioniert seit der 2.26.0.

Am besten sendest du mir mal die Daten für den Support Zugang per PN, dann schaue ich mir das einmal genauer an.

1 Like

Öha, das hatte ich gar nicht auf dem Schirm.
Regel? Beim Einlernen von EnOcean-Geräten immer alle Repeater stromlos machen?

Das kann auf jeden Fall nicht schaden. Eine Regel würde ich u.U. nicht gleich draus machen, aber es ist ein Punkt den man erwähnen und gegebenenfalls testen sollte wenn etwas nicht funktioniert.

Schaust Du hier:

Schwerpunkt:

2 Like

Also doch Regel, danke @Gregor

Nein, nicht ganz. Die Aussage bezieht sich auf eine spezifische Variante des Einlernens von EnOcean Geräten. Der hier besprochene Fensterkontakt verwendet eine andere Art.

rein prophylaktisch ist es aber empfohlen, weil die Anlernmethode uns ja weder bekannt ist noch irgendwo erläutert ist. Verständlich-soll ja einfach bleiben

ich werd es jedenfalls so handhaben beim weiteren enocean-Ausbau

2 Like

Hallo @Thomas, ja, hab einen Repeater im Einsatz. Wie vermutlich viele Leute, die Enocean einsetzen. Aber wie geschrieben hab ich keinen wirklich messbaren Einfluss gesehen, wenn ich den Repeater ausschalte. Klar, ohne Repeater gibt es deutlich weniger Funkverkehr, aber das scheint mir nicht die alleinige Ursache für das Problem zu sein. Ich schicke dir mal die Daten für meinen Support Zugang. Vielen Dank!

Hallo @Thomas
Das Problem mit dem Batteriezustand, dass er nicht angezeigt wird. Habe ich auch. Was kann ich da von meiner Seite her machen um dieses zu ändern.

1 Like

Bitte beim Einlernen bitte auf die Hinweise in der Anleitung in der App sowie dem Handbuch des Gerätes achten. Der Knopf darf nicht länger als 3 Sekunden gedrückt werden. In der App steht 2 Sekunden gedrückt halten, aber ein ganz kurzes Drücken von z.B. 0,2 Sekunden oder so genügt um das Gerät richtig einzulernen.

3 Like

Hallo @Thomas, vielen Dank! Mit abgeschaltetem Repeater und ganz kurzem Druck auf den Anlernknopf hat es geklappt. 2 Sekunden (habe 21, 22 gezählt) sind scheinbar schon zu lang. Danke für’s dranbleiben!

1 Like