Community

„Keine Antwort“ in HomeKit


#62

ich konnte nun etwas genauer analysieren: Alle direkt über HomeKit eingebundenen Geräte funktionieren (Kameras, Eve etc).

Alle von homee übertragenen Geräte sind nicht mehr verfügbar. Neustart von homee wie auch neue Synchronisation ohne Erfolg


#63

Ist die homee-Bridge überhaupt erreichbar? Wenn nein, erklärt das warum alle darüber angebundenen Geräte ebenfalls nicht errreichbar sind.


#64

Das sieht bei mir genauso aus. Alle Homekit Geräte oder die Lampen über der Hue Bridge funktionieren einwandfrei. Die Homee Bridge war beim ersten Versuch da, aber die Geräte gingen nicht. Nach dem ich die Homee Bridge aus dem Homekit rausgelöscht habe, kann ich sie auch NICHT mehr ins Homekit einbinden.
KH


#65

Traue mich gar nicht die 2.22 zu installieren. Hatte ebenfalls Probleme mit HomeKit Anbindung bis ich den Brain wechseln musste. Seitdem läuft es geschmeidig. Ich hoffe mit 2.22 kommen die Probleme nicht zurück.


#66

Da du ja die Verbindung bereits getrennt hast: schon versucht die Geräte zu deaktivieren und dann einzeln über Synchronisieren hinzugefügt?

@Det habe eben deine Konfiguration versucht. Konnte alle 24 Geräte ohne Fehler verbinden. :sweat:


#67

Hallo Volker, Du meinst Die Geräte in homee selber deaktivieren oder meinst Du in der homee Bridge? Ich bekomme ja die homee Bridge selber nicht mehr ans homekit angebunden.


#68

bei mir geht hier nichts mehr.
Nur Steuerung über homee direkt.
HomeKit ist tod


#69

In homee: Du kannst ja vor dem Verbinden, die explizit unter den Geräte-Einstellungen für HomeKit deaktivieren und danach das “Pairing” durchführen.


#70

Guten Morgen Volker, ich glaube ich brauche eine Brille :wink:
Die für Homekit auszuwählenden Geräte kann ich unter Homekit erst dann mit den Schalter auswählen, wenn die Homee Bridge erfolgreich mit Homekit verbunden wurde. Dann habe ich unter Homekit eine UI mit Schaltern. Aber ich kann die Homee Bridge nicht mehr an Homekit anbinden. Das ging aber vor 2.22 problemlos. Nicht das es Probleme mit dem neuen IOS 12.1.1 gibt?


#71

Guten Morgen,

nein sobald du den Aktivieren-Button betätigt hast, sind die Toggle verfügbar. Derzeit gibt es noch ein Anzeige-Bug: Indem du im QR-Code Fenster oben links auf Verbinden klickst, gelangt man auf die Geräte-Übersicht :wink:

Könntest du bitte den Support-Zugang per PN schicken? Ich würde gerne auch deine Geräte-Konfiguration in meinem HomeKit auf Fehler untersuchen. :slightly_smiling_face:


#72

Hallo Volker,

danke für Deine Unterstützung. Warum auch immer konnte ich gerade beim 3ten Anlauf die Homee Bridge wieder mit dem IPad in Homekit einbinden und alle Geräte sind wieder da.
Keine Ahnung warum es gestern nicht funktionierte. Wenn Du trotzdem gerne auf die Konfig schauen möchtest, kann ich Dir gerne den Support Zugang senden


#73

Habe eben auch deine Geräte-Liste geprüft: keinerlei Probleme, konnte direkt alle 19 Geräte hinzufügen. :man_shrugging:


#74

Seltsam, aber trotzdem Danke für Deine Mühe!!


#75

Guten Abend Volker,
Und wieder zeigen seit 24h alle Geräte in HomeKit „keine Antwort“

Es kann doch nicht die Lösung sein, regelmäßig homee oder Apple Gerät neu zu starten, um dann festzustellen das dies nichts brachte…

Konntest Du aus den Untersuchungen Ergebnisse ableiten?

Vielen Dank für ein Feedback


#76

Wie gesagt sind in den Gerätelisten keine Fehler mehr aufgetreten, welches früher immer zu Verbindungsabbrüchen geführt hat. Trotzdem nimmt das Smartphone diese manchmal erst nach dem x-ten Sendeversuch an. Zumal sehe ich das immer nur bei euch im Log, konnte es selbst aber noch nicht nachstellen (vllt zu wenige Geräte). :thinking:

Ich versuche euch mal zu erklären was da passiert:
Bei dem initialen “Pairing” wird eine sichere Verbindung aufgebaut. Dabei werden zwei geheime Schlüssel ausgetauscht. Einer dient zum Entschlüsseln der eingehenden Nachrichten und der andere zum Verschlüsseln der zu versendenden Nachrichten. Soweit alles kein Problem.
Nun wird nach längerer Inaktivität die komplette Geräteliste (JSON) versendet, dabei muss die relativ lange Nachricht in einzelne Frames aufgeteilt werden.

Each HTTP message is split into frames no larger than 1024 bytes. Each frame has the following format:

<2:AAD for little endian length of encrypted data (n) in bytes>
<n:encrypted data according to AEAD algorithm, up to 1024 bytes>
<16:authTag according to AEAD algorithm>

Entweder passiert nun folgendes:

Once session security has been established, if the accessory encounters a decryption failure then it must immediately close the connection used for the session.

oder was ich vermute ist, dass beim Versenden das Smartphone die Frames durcheinander bringt und daraufhin einfach eine erneute Anfrage stellt. :face_with_raised_eyebrow:

Solche Fehler bei dem keine Rückmeldung kommt, sind schwer zu analysieren und brauchen daher leider viel Zeit. Wir versuchen das natürlich trotzdem schnellst möglich zu beheben. :wink:


#77

Wie wäre es mit einem erweiterten Logging, wo die Logs optional an Euch gehen?


#78

Also ich habe jetzt mal versucht homee zu HomeKit hinzuzufügen. Sobald ich 34 Geräte direkt hinzufügen möchte, erscheint die Fehlermeldung “Nicht zertifiziertes Gerät”. Sobald es 33 sind, dann klappt es. Ich habe es mit unterschiedlichen Geräten ausprobiert.

Wenn ich über 30 Geräte manuell hinzufüge, dann habe ich wieder keine Antwort. Es scheint so als schafft homee nicht mehr als 30 Geräte.


#79

Bei mir schafft er nicht mal eins… :roll_eyes: auch egal welches.


#80

Ich stelle immer wieder fest, dass es bei der Verwendung mehrerer IPhone/iPads zu Problemen kommt.
Kann das eine - kommt beim anderen ewig lang ‚aktualisieren‘.
Siri hat zwischenzeitlich keine HomeKit steuerbaren Geräte bei dem einen, beim anderen funktioniert es Problemlos.


#81

Ich hab genau das Problem mit mehreren Gästen.