Homee v2 im lokalen Modus / lokale Webapp

So ein Homee ist toll. Allerdings habe ich mir den Homee geholt, um ihn zu 100% lokal zu betreiben. D.h. unabhängig von irgendwelche extern gehosteten Webapps.
Ich hatte den per Wlan angebundenen Homee zuerst versucht lokal zu erreichen. Also sprich über die IP und den Port 7861. Auch die URL hatte ich modifiziert von nichts zu webapp etc: bspw: http://192.168.x.x:7681/webpp
Leider alles ohne Erfolg. Der Port ist zwar offen und das Gerät antwortet, eine Webobefläche bekomme ich allerdings nicht zu sehen.
Also habe ich den Homee testhalber in den lokalen Modus versetzt, sprich: Eigener WLAN AP, keine Verbindung zu meinem WLAN. Mit dem Handy verbunden und mit der Erwartung dort auf eine lokale WEBUI zu kommen - leider Fehlanzeige. Ich bekomme zwar eine IP, kann damit aber auf keine Weboberfläche. Jetzt habe ich das Problem, dass Homee garnicht mehr erreichbar ist. Was tun?

1 Like

Danke für den Link - aber was hilft mir der?
Zertifizierungsstellen lokal für HTTPS Connections auf meinem Windowssystem zu importieren bringt mir für die Verbindung zu einem nicht mehr vorhandenem Endpoint garnix.

  1. Das feature der lokalen Webapp gibts nicht mehr, es bleibt nur noch die API für Android oder IOS übrig? Das ist jetzt nicht so toll. Seht ihr das als nebenbei zu erwähnende Info? Aufgrund von zu wenig lokalem Speicher im Homee? (Konstruktionsfehler?) Ist das Konzept von Homee nicht „lokal“? Ich will weg von Google und Co und werde an einen weiteren externen Service gebunden?
  2. Ich komm auch auf keine API über die Android App, wie soll ich da überhaupt verbinden?

Wie soll das funktionieren…

1 Like

Die Verbindung der IOSApp und der AndroidApp geschieht im LAN/WLAN lokal über die MAC. Diese entspricht Deiner homee-ID und daher solltest Du diese in einem Screenshot unkenntlich machen. Einen homee vollständig ohne Internet zu betreiben hat auch den Nachteil, dass man diverse Dienste (Wette, NTP,…) nicht mehr nutzen kann. Insbesondere ist homee dafür bekannt, dass sein Onboard-Uhr sehr schnell start abweicht. Ohne NTP sind dann zeitgesteuerte Abläufe nicht sinnvoll zu konfigurieren. Solltest Du von der Oberfläche her andere Vorstellungen haben, gibt es über eine inoffizielle API einen gut iobroker- und einen Nodered-Adapter.

Bzgl. der MAC hatte ich das auch gemerkt und eigentlich den Screenshot nochmal anonymisiert geuploaded … seltsam, auch nicht so wichtig.
Meine Frage war folgende: Wenn ich auf lokal switche, so dass der Homee ein eigenen AP aufmacht - wie komm ich dann noch auf den Homee?

Nur mit den Apps (IOS oder Android) oder mit einem Webbrowser, der die PWA geladen hat, wie es in der Anleitung beschrieben wurde.

Steh ich auf dem Schlauch?

  1. Die Anleitung beschreibt ausschließlich die Installation eines Zertifikats.
  2. In der AndroidApp habe ich keine Option eine lokale Verbindung zum Homee direkt aufzubauen.

Indem du dich mit dem WLAN vom homee verbindest.
Über die Android App und iOS App geht es lokal. Über die webapp nur, wenn du einmal die App online in den Cache speicherst. Anschließend kannst du über den Link oben auch offline und lokal mit der gecacheten webapp auf den homee zugreifen.

Da scheint das Problem zu liegen. Woher soll die Android App wissen, dass sie mit dem Homee WLAN verbunden ist? Meine tuts auf jeden Fall nicht:

Vielleicht wird das Problem ja jetzt ersichtlicher…
Ich hatte ja geschrieben:

„Also habe ich den Homee testhalber in den lokalen Modus versetzt, sprich: Eigener WLAN AP, keine Verbindung zu meinem WLAN. Mit dem Handy verbunden“

@svond welche IP hat dein WLAN, wenn du mit deinem homee WLAN verbunden bist?

@Steffen
10.13.37.20 / 24
gateway demnach .1

hier noch Mal ein paar allgemeine Infos zu dem Thema:

die genannte IP-Adresse sieht für mich nicht nach dem Netz eines homee-Würfels aus.

@annaeymnd
Ich bekomm die auf jeden Fall von dem Würfel:

auf jeden Fall ein umfassender Artikel - danke!

Ich hab so die Befürchtung, dass was mit dem speziellen Würfel nicht stimmt.

image

Auch nachm reset kann ich den nicht mehr verbinden.

Port 7681 ist nicht erreichbar?

Mal ein WLAN-Reset versucht?
WiFi-reset_DE (1).pdf (19,8 KB)

tatsächlich ist der Port doch erreichbar (telnet).

Hallo @svond,
hast Du denn mal, wenn dein Telefon mit dem WLAN des homees verbunden ist, auf „homee hinzufügen“ in der App getippt und deinen homee mittels ID und deinen Zugangsdaten verbunden? Von alleine taucht der da nicht auf…