Community

Absturz durch vollen Speicher

aufgenommen

#41

@simon2503: Das hört sich grundsätzlich gleich an wie unser Problem. Ich hatte auch schon automatische Neustarts ohne die Meldung “Speicher voll”. Entweder stürzt homee da einfach ab und startet neu, oder er ist aufgrund des vollen Speichers vielleicht auch nicht mehr in der Lage, den Tagebucheintrag zu machen.

Ich habe ja schon viel versucht aber noch keinen Downgrade. Deshalb bin ich sehr an dem Ergebnis interessiert, falls Du dich daran wagst.

Viele Grüße, Dieter


#42

Bei mir ist übrigens keine Besserung eingetreten.

Nach dem ich gestern den homee wieder an seinen alten Platz gebracht hatte habe ich wieder den gestaffelten Start durchgeführt, wie @JayJayX ihn vorgeschlagen hatte. Der Start wurde noch ohne Probleme durchgeführt, ca. 15 Minuten nachdem alle Würfel drauf waren hat er dann wieder einen Neustart wegen Speicher voll durchgeführt (das war 20:55 Uhr). In der Nacht dann weitere 3 Neustarts wegen vollem Speicher (21:13 Uhr, 00:18 Uhr und 02:19 Uhr). Morgens hatte ich dann wieder die Situation, dass alle zwave-Geräte als verfügbar angezeigt wurden, tatsächlich wurden kamen aber keine Informationen von den Sensoren an und es konnten auch keine Aktoren geschaltet werden.

Also wieder einen manuellen Neustart (diesmal Soft-Restart ohne Abschaltung) durchgeführt, das war gegen 10:30 Uhr.

Dann lief alles wieder ohne Probleme für immerhin fast 5 Stunden.
Seitdem wieder regelmäßig Neustarts wegen vollem Speicher (15:28 Uhr, 16:01 Uhr, 16:13 Uhr, 16:35 Uhr). Seitdem wieder LLS und kein einziges zwave-Gerät funktioniert.

Echt frustrierend.

homeean terminal hatte ich ausprobiert, danke @Kobold für den Tipp. Die erste Einwahl hatte auch funktionert, hier konnte ich keine verstärkten Aktivitäten einzelner Geräte feststellen. Aktuell ist (wie erwartet) Funkstille.

Es steht wohl der nächste Neustart an, dann funktioniert es vielleicht wieder für wenige Stunden.

CA hatte ich übrigens eingeschaltet, sie sehen sich aber aktuell nicht in der Lage zu helfen, erst wenn sie wieder besetzt sind.

Viele Grüße, Dieter


#43

shamrock: Bin mal auf die 2.21.0 gegangen. Werde berichten sobald ich Neuigkeiten habe.

Gruß simon


#44

Klasse, vielen Dank.


#45

Unter “Fehlerbehebung” kann man das Tagebuch zurücksetzen, Versuche das doch einmal.


#46

HighControl: mehrfach ohne Erfolg durchgeführt, aber Danke für den Hinweis.


#47

Hi,

ich habe heute durch Zufall gesehen das mein System um 21:33 Uhr gestartet wurde.
Davor befinden sich aber keine Tagebuch Einträge bezüglich vollen Speichern oder anderer Fehler.
Danach natürlich viele mit Werte werden aktualisiert, aber diesmal haben sich alle Geräte wieder gemeldet.

Kein voller Speicher aber ungewollter Neustart.


#48

Nachdem sich zwave bei mir überhaupt nicht mehr fängt und Unterstützung durch CA frühestens ab 07. Januar kommen wird habe ich mich jetzt doch zum Downgrade entschlossen.

Aktuell bin ich nur den kleinen Schritt auf die 2.22.0 gegangen und beobachte das aktuell, ob hier eine Verbesserung eintritt. Wenn nicht, dann gehe ich auf die 2.21.0 zurück. Dann muss ich ein BackUp mit den HGs zur Heizungssteuerung einspielen, da ich dann die Pläne nicht mehr nutzen kann.

Viele Grüße, Dieter


#49

Bei mir heute 3x Speicher voll und ausgestiegen der homee.
Ich habe darauf bald keine Lust mehr.
:confused:


#50

Ich habe ein erstes Erfolgserlebnis !!!
Ich konnte nach einer Woche vergeblicher Mühe endlich den Wall Plug für den Weihnachtsbaum einlernen und damit das neue Weihnachtsbaum-Icon verwenden :wink:


#51

Na alleine dafür hat sich das Icon gelohnt !


#52

Ich habs schon in der Slack Gruppe geschrieben. Das hört sich alles nach einem buffer overflow an. homee scheint so viele Daten zu bekommen, dass er es nicht mehr verarbeiten kann und sie in den Speicher schiebt, bis der voll ist.
Da läuft ein Sensor oder Aktor Amok. Findet mal heraus, ob die Betroffenen gleiche Geräte haben.
Sonst hilft Stück für Stück die Geräte stromlos zu machen, um so den Verursacher zu finden.


#53

shamrock: 2.21.0 läuft bei mir seit heute morgen stabil, bisher keine Probleme. Auch die ausgestiegen Fibaro Door Sensoren konnte ich wieder einlernen. 2.22.0 hat bei mir nicht funktioniert.


#54

Vielen Dank für die Rückmeldung. Bei mir läuft aktuell noch die 2.22.0 stabil, aber erst seit ein paar Stunden. Dann bereite ich mich mal auf die Rückkehr zur 2.21.0 vor, damit es dann schnell geht, wenn die Probleme wieder auftreten.

Vielen Dank und viele Grüße, Dieter


#55

Du bist aber mutig, ich traue mich nicht meinen neuen Popp Weather anzulernen. Habe Angst, dass das wieder los geht…

Das dieser Fehler erst seit der 2.21 auftritt und es nun immer mehr haben kriegen ist schon eigenartig.
Die 2.20 lief ohne diese Abstürze. CA muss das in den Griff bekommen…

Viele Grüße
JayJay


#56

Bei mir sind zuerst alle Fibaro Door Sensoren ausgefallen, erst nach dem Aufspielen der Version 2.21 konnte ich diese wieder anlernen. Hat das Problem noch jemand? Vielleicht liegt es an den Fibaros? Nur so ne Idee.


#57

Was meinst Du damit, das die zu erst ausgefallen sind?
Warum musstest Du die wieder anlernen? Waren die bei Dir komplett aus der Geräteliste verschwunden?
Ich denke nicht das es an den Fibaros liegt, dann hätten ja auch noch viele Andere das Problem, oder?

190 Stunden Uptime mit der 2.22.1 (hoffentlich bleibt es so)

Viele Grüße
JayJay


#58

Teilweise nur angegraut und konnten auch nicht zum Leben erweckt werden, teilweise aber auch komplett verschwunden.


#59

Wow, das ist schon extrem. So was hatte ich glaube ich noch nie… Verschwundene Geräte beim Anlernen, das ja…

Ich hoffe es läuft bei Dir jetzt weiterhin rund…

Viele Grüße
JayJay


#60

hm heißt das die Auslöser waren batteriebetriebene Z-Wave Geräte??