Community

Virtuelle Geräte in homee


#22

Hi, wie und mit welcher Software hast Du eigentlich die 433Mhz Geräte auf dem Pi eingebunden?
Hast Du dafür auch eine Anleitung?
thx!


#23

Die laufen auch über Node–RED. Habe an meinem Raspberry ein Funkmodul. Über WiringPi und RCSwitch kann man die Steckdosen dann steuern.
Ich habe eine Anleitung in Arbeit. Ich denke, dass ich sie bis zum WE veröffentlichen kann.


#24

Danke!


#25

@stfnhmplr Bei mir funktioniert Dein Beispiel mit der Lampe ein/ausschalten. Danke für das Tutorial. Allerdings habe ich noch eine Frage. Wie kann ich mit Homee die Farbe ändern? Und was bedeutet der Parameter “hue” im Playload. Diesen kann ich in der huemagic Doku nicht finden. Danke!


#26

Kannst du mal senden was du in der Funktion sendest ?

Die Farbe kannst du in verschiedenen Formaten einstellen.
Als Hex wert oder RGB oder …

Wenn das hue node antippst und auf Info rechts gehst dann siehst du die Eigenschaften die du an die hue senden kannst.

on On/Off boolean
hue HUE (0-359)
sat>/saturation Saturation (0-100%)
bri/brightness Brightness number (0-100%)
red Red (0-255)
green Green (0-255)
blue Blue (0-255)
hex Hex color
xy XY color (array with 0.0-1.0 values)
x and/or y XY color (0.0-1.0)
cr, mired or mirek Mired temperature color (153-500)
kelvin Kelvin temperature color (2200-6500)
duration Transition time (ms)
alert Alert effect (‘none’, ‘select’ or ‘lselect’)
effect Dynamic effect (‘none’ or ‘colorloop’)

Diese werte kannst du in der Funktion übergeben an die Hue.
VG


#27
var payload = {

“on”: msg.payload === ‘on’,
“bri”: 100,
“hue”: 120,
“sat”: 100
}

msg.payload = payload;

return msg;

@Micha Sorry war wohl gestern zu viel. Ich hatte das Beispiel von dem plugin “hueplus” kopiert. Selber habe ich aber “huemagic” verwendet. In huemagic gibt es ja diese Eigenschaften nicht bzw. lauten anderst. Jedoch wäre schon noch interressant wie ich die Farben mit homee in Verbindung mit node-red ändern kann bzw. wie ich die jetzigen Eigenschaften (wenn ich die Hue Lampen direkt in homee integriere) in node-red umsetzen kann. Danke!


#28

Leider kannst du die Farben über homee nicht ändern. Das musst du über Node-Red machen.
Du kannst aber die Farben je nach Bedingung in Node Red voreinstellen.
Du kannst auch alle hue Lampen darüber in den Alarm Modus setzen ( dann blinken alle).

Sinnvoll wäre hier eine Einbindung bzw ein Plugin für Node Red das eine wlan Color Lampe simuliert und diese dann in homee angelernt werden kann.

Der hue wert ist die Farbe.
Anstelle des hue wertes kannst du auch mit HEX und RGB arbeiten.

VG Micha


#29

@micha Danke für Deine Antwort!


#30

Guck mal: https://himpler.com/blog/433mhz-steckdosen-mit-dem-raspberry-pi-steuern


#31

Hallo,

ich habe folgendes Problem. Habe meine Hue Lampen mittels Node-Red eingebunden. Das hat auch alles problemlos funktioniert.
Jetzt zu meinem Problem. Wenn ich den Raspberry oder homee neu starte kann ich nicht mehr auf die Lampen zugreifen. Sie sind in der Homee App hellgrau hinterlegt. Wenn ich die Lampe lösche, neu hinzufüge, funktioniert es wieder.
Habt Ihr eine Idee woran das liegen kann?
danke
michi


#32

Genau das gleiche Verhalten habe ich auch.


#33

Wie habt ihr die Ports vergeben für die wemo?
Habe davon 10 Stück in homee und sie steigen nicht aus, trotz Neustart von homee und Node Red.

Aber dieses Problem tritt scheinbar öfter auf.

Wie seit ihr beim speichern der Flow vorgegangen ?
Hier muss es ja ein Problem mit der Identifikation geben, da die Geräte ja homee angeboten werden.
VG


#34

Guten Morgen,

ich habe ebenfalls das Problem mit den Wemo-Emus.
Von den Ursprünglichen 12 liefen immer nur 10 und bei dem Versuch alle unter zu bekommen, sind es nun nur noch 8 Geräte die einen Neustart überleben. Dabei hat weder die automatische noch die manuelle Portvergabe etwas geändert.
Flows speichere ich immer mit “modified nodes”.

Eigentlich alles so wie es sein soll, nicht?

Viele Grüße
JayJay


#35

Ich hatte 4 Wemo-Emus laufen, nach einem Neuaufsetzten des Pi’s blieb nur noch einer dauerhaft verbunden. Die anderen drei waren nach einem homee- bzw. Node Red Neustart auch immer wieder ausgegraut und konnten nur durch Neuanlagen und Neuverbinden wieder connectetd werden. Nach vielen Versuchen die Demos dauerhaft zu verbinden hat homee selbst auf den verblieben Wemo allergisch reagiert und regelmäßig neu gestartet. Inzwischen nutze ich es nicht mehr und habe meine Hue’s per Webhook über die Hue API eingebunden.

Viele Grüße
Sven


#36

Ich schau mir das nochmal an. Scheinbar liegt das an der eindeutigen Identifikation. Mittelfristig will ich so oder so die virtuellen Geräte als Homematic Geräte emulieren. Da sind die Möglichkeiten größer. Aber soweit bin ich noch nicht.


#37

Ich hab es genau so gemacht wie von Stefan beschrieben.


#38

Selbes Problem bei mir.

Allerdings scheint es bei mir mit dem Harmony Flow in Node-Red zusammen zu hängen. Auf der Node-Red Oberfläche kommt es immer wieder zu der Meldung, dass der Server disconnected ist. In der Konsole sehe ich dann dass Node-Red immer wieder Probleme mit Harmony hat:

Disconnected from Harmony Hub: Error: Timed out after 50000 ms

Nach 6 Versuchen ist dann Node-Red nicht mehr gestartet. Warum weiß ich nicht. Dann ist natürlich der WEMO-Emu auch in homee nicht mehr zu erreichen…

Gruß Ralf


#39

Nur zur Info:
Das Problem ist, dass Alexa jetzt auch über Node-Red erstellte WeMo Geräte bei der Suche findet.
(Scheinbar nur über die Webseite, passiert nicht in der App)
Danach funktioniert “Alexa, schalte das Licht ein” nicht mehr.
Lösung: Einfach das WeMo Gerät löschen!


#40

Hallo an Alle

Ich habe heute was für Node Red gefunden.

https://www.npmjs.com/package/node-red-contrib-homekit

Sehr Interessant und es funktioniert :grinning:

VG Micha


#41

:heart_eyes: Danke @Micha