Shelly: Verlaufsgrafik ohne aktueller Werte, Werte aber da

Seit Montag ca. 14:00 Uhr werden in der App (Android & WebApp) von meinen ShellyUnis in der Verlaufsgrafik keine aktuellen Werte mehr angezeigt (-> Balken quasi waagrecht, als wäre es noch derselbe alte Wert):


weiter unten, wo der aktuelle Messwert angezeigt wird, wird aber korrekt der aktuelle Messwert angezeigt (der sich auch seit Montag 14:00 Uhr mehrmals geändert hat…)

Ich weiß nicht genau, warum dies seit Montag ca. 14:00 Uhr ist. Möglicherweise war da da Update der Android-App auf 2.38 … aber das Problem tritt ja auch in der WebApp auf??!

Was bedeutet die Markierung des Threads mit „information-benötigt“ (ohne Info, was genau noch benötigt wird)?

2 „Gefällt mir“

An welchen Ausgang vom Shelly hängt der Sensor? Zwei aktuelle Screenshot von meinem Shelly UNI


das sind die Werte vom DHT22 Sensor angeschlossen an VCC_Sensor DATA_Sensor GND_Sensor Leitung 4 5 6.
Bei mir klappt das aktualisieren der Werte der DC Spannung an ADC_Input nicht.

Welchen Sensor verwendest du am UNI?

DS18B20, also auch gemäß Skizze Anschlüsse 4, 5 und 6.
Und: Die Werte werden ja eh übertragen, Probleme mach der Verlauf (die Grafik)??

1 „Gefällt mir“

Ich habe einfach die Verlaufsdaten gelöscht, nun scheint es wieder zu gehen. Leider halt mit Datenverlust verbunden…

1 „Gefällt mir“

Das Problem tritt schon wieder auf.
Es wäre schön, wenn es eine andere Lösung als das Löschen der Verlaufsdaten (Datenverlust) gäbe…

Hinweis: Die vorm Zurücksetzen des Verlaufs gesicherten Daten erwecken den Anschein, als wurden einfach keine weiteren Verlaufsdaten mehr gespeichert, weshalb auch die Grafik den geraden Strich darstellte (Verbindung vom letzten gespeicherten Messpunkt zum aktuellen Wert).
Es wäre also zu klären, weshalb die Verlaufsdatenspeicherung plötzlich aufhört? Speicherproblem? (Falls der Speicher voll wäre, sollte da nicht ein Hinweis kommen bzw. (ähnlich wie bei Wetterstationen mit Ringspeicher) einfach die ältesten Werte gelöscht werden?)

Erneut ungef. 1 Monat später und das Problem tritt wieder auf. Seit heute ca. 11:43 Uhr werden offenbar keine Verlaufsdaten mehr gespeichert, Symptomatik wie im ersten Beitrag bzw. in meinem letzten Hinweis:

@Steffen Es wäre also zu klären, weshalb die Verlaufsdatenspeicherung plötzlich aufhört? Speicherproblem? (Falls der Speicher voll wäre, sollte da nicht ein Hinweis kommen bzw. (ähnlich wie bei Wetterstationen mit Ringspeicher) einfach die ältesten Werte gelöscht werden?) … noch dazu, wo das Problem jedes Monat wiederkehrt…
(Supportzugang kommt gleich per PN)

2 „Gefällt mir“

@Steffen Problem tritt erneut auf (also wirklich regelmäßig 1 Monat nach dem Zurücksetzen der Verlaufsdaten) - Supportzugang kommt per PN

Gleiches Problem bei mir.

Guten Morgen,

wir sehen uns gerade dazu ein Fix für die Datenbank an, ich kann aktuell aber noch nicht sagen ob es schon mit der Version 2.39 veröffentlicht werden kann, aber wir Arbeiteten fieberhaft dran es so schnell wie möglich zu Releasen. :muscle:

2 „Gefällt mir“

Hört sich gut an.
Vielen Dank.

Oh, was für eine schöne Aussicht. :slightly_smiling_face:

Danke für die Ankündigung. :+1:

Und viel Erfolg bei der Fertigstellung!

Das mit den Verlaufsgrafiken hatte ich hier bei dem Thema auch:
Shelly Geräte werden in als nicht erreichbar dargestellt - Support und Bugs / Shelly - homee | Community

Aktuell kann ich auch keinen Shelly 3PM einbinden weil dann sich der Homee verlangsamt und nicht mehr richtig schalten kann - vermutlich auch wegen dem DB Thema. Fühlt sich so an als ob der Shelly 3PM die DB vollschreibt und das dann das zeitverzögern auslöst beim Homee. Nach Reboot gehts wieder für kurze zeit.

@mosmax (und @Steffen )
Das Problem im Thread von moxmax ist sicherlich ein anderes. Dort zeigt halt die Verlaufsgrafik einen waagrechten Strich, wenn die Shellys nicht verfügbar sind. Dies ist logisch, da sich dann die Messwerte nicht ändern.
Bei mir sind ja alle Shellys erreichbar und es gibt offenbar nur ein Problem mit der Datenbank - halt immer wieder, regelmäßig! Derzeit hilft ja nur das Zurücksetzen des kompletten Verlaufs … dann läuft der Verlauf wieder für ca. 30 Tage.

Bei mir werden die Verlaufsdaten auch nicht mehr angezeigt.
Es betrifft aber nicht nur Shelly-Geräte!

Ausgerechnet jetzt, wo ich mich intensiv mit den Verbräuchen auseinandersetzen will, um ein Gefühl für eine sinnvolle PV-Auslegung zu bekommen.

Dann würde ich die Verlaufsdatenbank mal komplett zurücksetzen. Dazu die Speicherung der Verläufe in den Einstellungen des homee (nicht in den Einstellungen der Geräte) ausschalten und wieder einschalten. Dann wird die Datenbank wieder angelegt.
Allen, denen die Verlaufsdaten sehr wichtig sind, kann ich nur raten, die Daten täglich über den CSV-Export auf einen FTP-Server oder in die Dropbox zu sichern. Die Verlaufsdatenbank des homee reagiert wie viele andere Datenbanke auf anderen Systemen auf Stromausfälle pingelig.

Gibt es eine Möglichkeit, die Verlaufsdaten direkt zu exportieren?
Ich finde keine Option in den Einstellungen und auch nicht im Shelly 3em-Gerät.
Über Nacht hat heute nicht geklappt. Ich habe die Option in den Einstellungen deaktiviert und noch einmal aktiviert und einen anderen Pfad vorgegeben.

Nein.

Bei der nächtlichen Sicherung per CSV-Export werden auch immer nur die Daten des aktuellen Tages gesichert. Dabei wird für jedes zu sichernde Gerät eine Datei angelegt.
Wenn Dir das in der Nachbearbeitung zu umständlich ist, kann ich nur empfehlen, die Daten über den iobroker-Adapter zu ziehen und dort in dem history-Adapter abzulegen. Die dort abgespeicherten Daten kannst Du dann beliebige weiter bearbeiten oder grafisch ausgeben.

Danke für die Klarstellung.

Damit werde ich mich in Kürze auseinandersetzen. Leider sind die Raspberries im Moment so teuer :frowning: