Community

OOMI Plug Zwischenstecker


#82

Hi,
ich hatte meinen mehrfach neu geflashed, leider ohne Änderung…


#83

Das gleiche habe ich auch mit einem geflashten. Die anderen habe ich dann alle Orginal gelassen.

Naja zum schalten geht der jedenfalls.


#84

Ok, schade. Warten wir Mal die Antwort von Aeotec ab.


#85

OK, also Aeotec hat mir die Oomi Firmware geschickt. Das zip File kann genauso wie die Original Aeotec Firmware installiert werden.

Ich kann das gerade nicht testen, da ich meinen zwave Stick verliehen habe und erst am Montag die FW flashen kann.

Wie kann ich am besten die Datei verteilen, für den der will?
Schreibt mir per PN, dann schicke ich euch die zip zu. Oder kann ich die hier zum Download anbieten?

WICHTIG: FALLS DURCH DAS FLASHEN EUER OOMI PLUG GANZ KAPUTT GEHT, DANN UBERNEHME ICH KEINE HAFTUNG!!! Alles auf eigene Gefahr versteht sich.


#86

Leider kann ich die Funktionsweise der Aktualisierung für FT096 nicht bestätigen. Es geht aber die Zwischensteckdose wenigstens auch nicht kaputt.

Die Aktualisierung verläuft vollständig (Dialog “succeeded”) mit COMMAND_CLASS_FIRMWARE_UPDATE_MD.FIRMWARE_UPDATE_MD_STATUS_REPORT, allerdings der Daten FF 00anstelle FF 01. Ich tippe auf eine Ablehnung der Firmware wegen der Manufacturer-ID (nicht Aeotec 0x0086 wie die bestehende, falsche Firmware, sondern Fantem 0x016a), da die vorherige Prüfung COMMAND_CLASS_FIRMWARE_UPDATE_MD.FIRMWARE_UPDATE_MD_REQUEST_GET mit der Aotec Hardware-ID durch die Firmware bestätigt wird.


#87

Schade. Hatte ja klappen können. Ich probiere es auch noch an Montag aus und sende Aeotec die Fehlermeldung.

Die Frage wäre nun, wie hoch ist das Interesse Aeotec weiter mit dem Thema zu beschäftigen?


#88

Hallo Rhocco,

hast du es schon probiert und wie ist das Ergebnis?


#89

Hi ne leider noch nicht. Kollege hat mir erst heute den Z-Wave Stick wieder gebracht. Werde heute Abend mal versuchen.


#90

So, flashen geht reibungslos und ohne Fehler durch. Mit der Software die in der zip drin ist. Einfach die *.ex_ in *.exe umbenennen und dann kann man damit und dem Aeotec z-wave Stick die Firmware flashen.

ABER

Nach dem einbinden in homee, taucht es wieder als Aeotec Smart Switch auf und zeigt die gleichen fehlerhaften Werte an. Das flashen schlägt also doch fehl.

Ich gebe jetzt auf, war einen Versuch Wert.


#91

Wenn aoectec in der Firmware also die Hardware ID auf Oomi korrigiert sollte die Chance eines Erfolges bestehen.


#93

Ich gehe von genau dem umgekehrten Fall aus, weshalb ich auch denke, Aeotec würde nochmals helfen.

  • Hat Aeotec direkt in ihrem Firmware-Update-Tool eine Prüfung auf vendor != 0086 (Aeotec) und vendor != 016a (Fantem), weshalb man die Plugs erst “kaputt” flashen konnte.
  • Läuft das Update, aber der Plug selber sagt dann sinngemäß nach Erhalt der Firmware “nö, mache ich nicht”. Das hat eine von zwei Ursachen: Entweder prüft der Plug mit Aeotec-Firmware auf die ID und sagt bei Fantem, dass er die nicht annimmt, oder die Prüfsumme ist falsch (unwahrscheinlich).
  • Wenn erstere Annahme zutrifft, müsste also die Firmware weiter die Aeotec-Vendor-ID tragen, damit der Plug sie annimmt.

#94

Kann es gerade nicht testen… hat sich jemand schon mal den Parameter 200 angeschaut in dem Zusammenhang?


#95

Interessant, die Aeotec Smart Switch 6 Firmware ist nicht mehr über ihre Webseite verfügbar. Entweder kommt eine neue Version oder man ist sich der Problematik des versehentlichen Überschreibens der (dock inkompatiblen Oomi Plug Firmware) durchaus bewusst.

Vielleicht hat @Rhocco sich ja noch einmal mit dem Aeotec-Support in Verbindung gesetzt, der Parameter 200 aber ist nicht relevant für die Firmwareaktualisierung (252 auch nicht, so am Rand).