Community

Node Red - Hilfe-/Frage-/Ideen-/Austausch - Thread


#41

Habe auch ein Debug Node rangehängt. Bei mir erscheint aber immer nur:

switch/bulb : msg.payload : string[2]
“on”

Was mache ich falsch?


#42

Guten Morgen @CaptainL,

Wir haben es über das homee Node gelöst.


Das hier steht in der Funktion

var nodeid = 000; // node ID in homee vom Wemo
var attributid = 000; // attribut ID in homee vom Wemo
if (msg.payload.on === false)
{return {payload: “PUT:/nodes/”+nodeid+"/attributes/"+attributid+"?target_value=0"}}
if (msg.payload.on === true)
{return {payload: “PUT:/nodes/”+nodeid+"/attributes/"+attributid+"?target_value=1"}}


#43

Moin @Micha, vielen Dank mal wieder für deine schnelle Hilfe. Es funktioniert :blush:
Jetzt kommen die anderen Lampen dran, die vom Zigbee-Cube wieder zur Bridge umziehen. Hier ist die Zuverlässigkeit deutlich höher und auch kein Ausgrauen mehr…


#44

Mal noch eine Verständnisfrage in die Runde. Muss ich für jeden Wemo Emu einen neuen Port vergeben? Beim Verwenden des gleichen Ports gab es nämlich gerade ein Fehlermeldung.


#45

Ja das solltest du machen.


#46

Hallo zusammen,

ich nutze auch zahlreiche Wemos, mit denen ich mir neben meinem Saugrobbi, auch andere Stati anzeigen lasse.
Jetzt möchte ich praktisch bei Änderung des Wemo Schaltzustandes (Rückmeldung kommt bereits aus homee) jeweils eine entsprechende Push über Pushbullit erhalten.
Ich komme aber nicht mit der Funktion klar und wie ich die Nachrichten “differenziere”:

Funktion sieht so aus:
if (msg.payload === “on”) {
msg.payload = “PC Linus geht online.”
return msg;
} else if (msg.payload === “off”) {
msg.payload = “PC Linus ist wieder offline.”
return msg;
}

image

Was muß ich da reinschreiben???


#47

Ich sende mir die Nachrichten an Telegram.
Das andere muss ich mir mal anschauen😀


#48

Es geht rein um die Funktion. Pushbullit läuft soweit super.
Aber hier kommt kein Payload aus der Funktion…

EDIT: der Status des Wemo (Orange) scheint irgendwie nicht auswertbar zu sein. Kann das sein?
Ich habe es jetzt über einen Umweg mit einem Switch gelöst :wink:

Etwas umständlich, aber es funktioniert zuverlässig.


#49

Du hast da scheinbar nur einen Denkfehler drin.
Der orangene wemo liefert Dir einen payload je nach geschalteten Zustand.
Der Umweg über deine Switche ist etwas umständlich bzw. geht auch anders.
Umständlich ist da nicht das richtige Wort, viele Wege führen nach Rom.:grinning:


#50

Hat jemand von Euch den Philips Hue Dimmschalter über NodeRed eingebunden? Wie habt ihr das realisiert?

Ich verwende ihn nur als Auslöser für HGs. Wie setze ich das am besten um? Mit zwei Wemos?


#51

Warum WeMo’s? Hast Du das homee Plugin den nicht installiert?
Ich würde die Automatisierung in dem Fall entweder komplett in Node Red abbilden, oder ein Flow erstellen welcher beim betätigen des Schalters ein bestimmtes HG ausführt.


#52

Danke für deine Rückmeldung. Plugin ist installiert. Nur mir sind die Möglichkeiten mit NodeRed noch nicht so geläufig :see_no_evil:

Ich würde […] ein Flow erstellen welcher beim betätigen des Schalters ein bestimmtes HG ausführt.

Auf die Idee bin ich nicht gekommen… Und die HGs löse ich dann über Webhooks aus oder kann ich die Ausführung auch über eine ID steuern?


#53

Ja, so mache ich das auch. z.B. um mein Feiertags HG zu aktivieren und zu deaktivieren.
Du kannst über die homegram ID die HG’s aktivieren/deaktivieren und abspielen.

Den Dimmschalter hat ja vier Tasten, die kannst Du mit ‘msg.payload.name’ abfragen:


#54

Moin,
habe das Problem, dass mit dem Huemagic Node Lampen sich automatisch schalten… d.h. z.B., dass sich Lampen nach dem Anschalten wieder aus- oder nach dem Ausschalten wieder anschalten.
Die Wemo Zustande sind korrekt… denke das kommt irgendwie von der Hue-Bridge und hängt m it dem Huemagic Node zusammen… insbesondere habe ich das Gefühl, dass das Verhalten nach Benutzung des Entertainment Modus der Bridge auftritt.

Kennt jemand das? Sind vielleicht andere Hue Nodes besser?

Wenn ich dann die Funktion im Flow dann neu eintrage und deploye, ist das Problem erstmal wieder gelöst.


#55

Nimm mal ins anderes hue Node .
Ich benutze contrib-hue.
Das gleiche hatte ich gestern auch festgestellt, als ich für @fisch mir was angeschaut habe.
:open_mouth::thinking:


#56

contrib-hue oder contrib-node-hue?
contrib-hue ist Version 0.0.5, zuletzt aktualisiert vor 4 Jahren?

Ich glaube, dass ich auch hue-plus noch brauche…


#57

Habe ich auch feststellen müssen, allerdings nur bei den ersten 1-2 Schaltungen. Danach funktioniert alles wunderbar. Egal ob über die Hue App geschaltet oder über homee App (WeMo)
Dachte zuerst, dass ich einen Fehler in den Flows hätte.


#58

Frage in die Runde zum Thema “Szenen”: Baut ihr die in Hue auf und schaltet via Node Red die Szene oder nutzt jemand die Szenen Funktionalität aus IOB bzw. Schaltungen wie “Kino” dann aus homee heraus?


#59

Da gibt es mehrere Möglichkeiten.
Ich erstelle zum Schalten von ZigBee Lampen die Szenen gerne in der Hue App.
Sollen zusätzlich Geräte die in homee integriert sind geschaltet werden, erstelle ich dazu ein Flow in Node Red, die dann beim Auslösen der Szene geschaltet werden. Die Szenen werden bei mir per Siri, über die Hue App oder in weitere HG‘s in homee geschaltet.


#60

Nabend,

habe den homee node ja schon installiert gehabt.
Ich frage mich gerade, wie ich eine Statusänderung eines Geräts (in dem Fall eines FT55) in NodeRed verwenden kann…

So als Art Homegramm, eben nur in NodeRed.