Community

iRobot i7 per IFTTT in Homee einbinden

Hallo zusammen,

ich würde gerne meinen iRobot über die entsprechenden Homeegramme per Webhook steuern. Leider steige ich bei IFTTT nicht so richtig durch, was ich in die einzelnen Felder eintragen muss. Kann mir jemand hier weiterhelfen???

Evtl. hilft dir ja dieser Thread etwas weiter… Viel Erfolg!

Welchen Thread meinst du Jensen78?

Uuups^^ Den Link nicht reinkopiert. Mea culpa!

Ich bekomme auf IFTTT immer einen Fehler angezeigt: Missing required trigger fields. Ich weiß nur nicht was falsch sein soll… Ich gebe doch erst bei Tigger den Webhook an und danach bei Action wähle ich iRobot aus.

Zeig doch mal das HG und die URL vom Webhook. Dann kann dir hier aus der Community bestimmt jemand helfen.

…aber die Webhooks (IDs) bitte verfremden…

Ich habe jetzt mal screenshots erstellt. Ich hoffe jemand hat eine Idee was ich falsch mache… :slight_smile:




edit:

Ich sehe da nichts was falsch ist…

Hoffe dir kann da noch jemand helfen.

Ich sehe auch nichts.

Startet der Sauger denn, wenn du das IFTTT Rezept händisch ausführst / testest?

:coffee:

Ne, das funktioniert leider auch nicht…

Ergänzung:
Als Fehler wird mir immer angezeigt:

Missing required trigger fields

Ich habe leider keinen irobot. Würde zunächst versuchen, dass das Rezept beim Testen sauber läuft. Habe mit dem gute Erfahrungen gemacht. Vielleicht kann dir da jemand helfen?
https://www.roboter-forum.com/index.php?board/67-irobot/
Wenn das läuft, können wir nochmal auf den Trigger durch homee schauen.
:coffee:

@coffeelover
Danke für den Link. Ich probier hier mal mein Glück. Wie würdest du die von mir genannte Fehlermeldung deuten? Klingt doch eigentlich schon nach einer fehlerhaften Konfiguration oder?

Ja, klingt nach einer fehlerhaften Konfiguration. Da das Rezept aber auch beim Testen (also beim händischen Auslösen) nicht funktioniert, scheint (auch) hier ein Fehler zu liegen.

:coffee:

Edit: Die Connects für Webhooks (oben verlinkt) und auf den iRobot hast du aber durchgeführt und siehst beide unter “My Services”?

ja, sowohl Webhooks als auch iRobot werden mir unter “My Services” angezeigt.

Edit:
Es hat geklappt!!! Ich musste nach dem “connect” nochmal den Befehl im Applet angeben.

2019-08-06%2009_11_09-Window

2 Like

Sehr cool. Freut mich!

:coffee:

:+1: