Geofence IOS

beim betreten oder verlassen ändert sich der Anwesenheitsstatus nicht.

In der Stable 2.31 ändert sich bei mir (IOS App) der Status der Benutzer nicht.

Bin jetzt extra bisschen unterwegs gewesen zum testen, aber leider verändert sich nichts.

Gibt es irgendwelche Tricks?
IOS 14.2
Core 2.31
App 2.31

manuelles setzen geht.

Edit: Dies hier ist mir aufgefallen, im vergleich zu anderen Apps die den Standort auch immer benutzen dürfen.

iOS:

Um die automatische Anwesenheitserkennung von homee zu aktivieren, müssen folgende Schritte unternommen werden:

  • Gehe zuerst in die Einstellungen in der homee App und aktiviere folgende Einstellungen.
  • “Einstellungen > Benutzer > Automatische Anwesenheitserkennung > Geofence aktivieren“
  • homee wird dich fragen ob es auf deinen Standort zugreifen darf. Das muss mit folgender Auswahl bestätigt werden: „Zulassen, dass homee den Gerätestandort abruft“ mit „Immer Zulassen“ bestätigen.
  • Es muss ein Bereich für die Automatische Anwesenheitserkennung festgelegt werden. (Der Radius kann jederzeit angepasst werden) danach muss die Einstellung mit dem Häckchen bestätigt werden.
  • Berechtigungen auf dem iOS Gerät überprüfen (Einstellungen > homee > Standort > „Immer“) muss bestätigt sein.
  • Es müssen noch die Berechtigungen auf dem iOS Gerät überprüft werden. Die homee App benötigt eine Berechtigung vom iOS System um deinen Standort abfragen zu dürfen. In den Einstellungen muss folgender Punkt bestätigt werden: (Einstellungen > homee > Standort > „Immer“).
  • Nach ein paar Tagen wird homee erneut nach einer Bestätigung fragen. Auch das muss mit “immer zulassen” bestätigt werden.

Danke für die schnelle antwort.

wie oben zu sehen ist, steht die berechtigung auf „immer“

geofence ist aktiviert und der Radius auf 100m festgelegt.

was mir nicht klar ist wo soll in IOS ein „häckchen“ sein soll
sehe nur iben rechts speichern

davon abgesehen, kam keine frage nach der berechtigung, beim aktivieren.
Hab es manuell machen müssen.

Bei mir gab es auf diese Frage aus der homee App heraus nur die Optionen:

  • Nur Einmal Zulassen
  • Nur beim Verwenden der App
  • Niemals

cheers,
spoocs

gerade vei meiner Frau getestet (ebenfalls IOS 14.2) die hat auch nur diese möglichkeiten zur auswahl gehabt.

Das „immer“ zulassen, muss man dann explizit in den iPhone Settings der homee App einstellen - dort gibt es die Option natürlich.

cheers,
spoocs

1 Like

genau das hab ich dann auch so getan

Viele Dank für euer Feedback, habe gerade es nochmal ein wenig angepasst.

Wir haben das mit einer etwas anderen Version erstellt, die sich jetzt noch ein wenig verändert hatte.

Diese Möglichkeit hatte ich weder auf meinem Handy noch auf dem meiner Frau.

Hab es dann manuell über die Einstellungen gesetzt. Ich denke da müsste noch nachgearbeitet werden. Viele User werden erst mal nur sehen, dass die Anwesenheit nicht richtig funktioniert, da eben nicht „Immer“ zur Auswahl stand und dann erst auf Fehlersuche gehen.

@Masipulami diese Anfrage sollte bei ersten verlassen/betreten eigentlich erscheinen :thinking:, kam das bei dir nicht?

@Steffen Bei mir kam auch gar keine Abfrage. Bei meiner Frau gabs die Auswahlmöglichkeiten „immer“ nicht, wie bei anderen oben auch

Sollte diese Abfrage nicht eig kommen wenn man auf Geofence aktivieren klickt? oder beim verlassen/betretten das verwirrt mich jetzt etwas

Ich hab diese Frage beim Aktivieren von Geofence bekommen. Da gabs kein „Immer“ zur Auswahl.

Hab seit der Aktivierung das Haus noch nicht verlassen.

Muss man mit seinem Account (Benutzer) auf anderen Geräten ausgeloggt sein, damit nur der Standort des iPhone genutzt werden kann?

das ist eine sehr gute Frage! Oder muss man für jedes Gerät einen eigenen Nutzer anlegen?

@Steffen ist es normal das unter Benutzer-> Geräte die Verbindung getrennt wird, sobald man nicht mehr aktiv in der App ist?

Kann man testen, in dem man von einem anderen Benutzer auf die Geräte des anderen Benutzers guckt, wären das Handy gesperrt ist.

Hatte iwie gelesen das die Apps verbinden sein müssen…

@Masipulami kannst du mir mal bitte mitteilen, welche iOS Version du nutzt?

14.2 auf nem iPhone XR.

Bei meiner Frau ebenfalls 14.2 auf nem iPhone SE.

@spoocs and @Speedo hatten ja scheinbar auch das gleiche Verhalten.

Du kannst auf jedem Gerät individuell einstellen, ob das Geofencing aktiviert werden soll, oder nicht. Nur die das aktivieren des Anwesenheitsmanagement für den Benutzer ist global für alle seine Geräte. Die Art wie das gemacht wird ist dann wieder auf jedem Gerät individuell. Allerdings gibt es natürlich nur einen Anwesenheitsstatus pro Benutzer.

Ich hab die ähnliche Thematik wie oben schon erwähnt.

Als ich heute Morgen das Haus verlassen habe, hat homee NICHT die Geofence beachtet.
Daraufhin manuell den Geostatus in den iOS Einstellungen für die homee App auf „immer“ geändert.
-> homee hat sich nicht aktualisiert.

Kann es sein, dass homee nicht in Intervallen den Standort abfragt und dann ggf. ein „Versäumnis“ nachholt, sondern , dass hierzu immer eine aktive „ÄNDERUNG“ (also betreten oder verlassen der Geozone) erforderlich ist?

1 Like