Community

Anwesenheitserkennung mit homeean presence


#181

Zudem brauchst du in presence einen echten Statuswechsel deines Beacons/Geräts, damit der Webhook feuert. Der Modus-Wechsel im homee reicht da nicht.

cheers,
spoocs


#182

@spoocs Na ja da ich auch die IP Eingetragen habe müsste es trotzdem funktionieren, sobald ich mit dem Handy im Wlan bin, der. Die beiden Einträge der IP und MAC habe ja nichts miteinander zu tun. Wenn ich es richtig verstehe sollte es reichen, dass ein Gerät da ist. Das heißt wenn ich Wlan ausschalte müsste der der Status auf abwesend und wenn ich es wieder einschalte auf Anwesend stehen ( nach einer gewissen Zeit natürlich).

Gruß
Christoph


#183

Na da gibt es nix zu entschuldigen…

Du bist ja jetzt schon mal einen Schritt weiter. Homeean Presence läuft. Du siehst in deinem letzten Screenshot auch, dass dein Smartphone erkannt wurde. Von der Erkennungsseite also erstmal alles gut.

Zur Funktionsweise: Der Webhook wird nur ausgeführt, wenn der Status auch tatsächlich gewechselt hat. Und zwar nicht der Status von homee, sondern der Status in homeean presence.
Heißt konkret: Melde dein Smartphone mal vom WLAN ab und bring den Beacon ausser Reichweite. Warte mindestens den threshold (bei dir 300 Sekunden) ab. Danach wird das Gerät und die Person als Abwesend erkannt. Es ist also ein Statuswechsel erfolgt, der Webhook für Abwesend wird ausgeführt.
Jetzt kannst du das Wlan am Smartphone wieder aktivieren. Dann sollte innerhalb von einer Minute der Webhook für Anwesend ausgeführt werden. Alle Aktionen kannst du auch im Logfile unter ~/.homeean-presence/homeean-presence.log nachlesen.


#184

@stfnhmplr Ok. Guter Hinweis. Das könnte in der Tat mein Problem sein. Ich habe das Hnady zwar aus dem Wlan genommen, aber der Beacon hängt immer noch 2 Meter vom raspberry :slight_smile: . Ich teste morgen früh weiter wenn ich zur Arbeit fahre, dann bin ich mit beiden Geräten weit genug weg :slight_smile:

Danke und Gruß
Christoph


#185

@stfnhmplr Heute morgen, als ich aus dem Haus war, hat der Statuswechsel tadellos funktioniert. Danke für den Hinweis. Jetzt muss ich nur noch den Beacon von meiner Frau noch einbinden :-).


#186

Hi,

noch eine Frage an @stfnhmplr: wenn es mir bei unserem Zwei-G-Tag Haushalt nur darum geht, dem homee ein Moduswechsel zu verpassen, wenn “keiner” mehr da ist bzw. wenn der “erste” wiederkommt (d.h. die globalen Webhooks), könnte ich also auch den “webhooks”: {}" -Bereich bei den einzelnen Personen in der Config einfach komplett rausschmeissen, und alles funktioniert weiter sauber? Die brauch ja eigentlich nicht.

Zumindest auf der homeean-Seite klingen sie ja eher optional.

cheers,
spoocs


#187

Ja, die Webhooks zur einzelnen Person sind optional. Du kannst das dann aus der Konfiguration komplett rausnehmen. So habe ich das bei mir auch eingestellt.


#188

@stfnhmplr: eine weitere Frage :wink: Weil ich dazu nichts gefunden hab.

Das Logfile wächst bei interval=10 und mehreren BLEs ja doch recht schnell. Geloggt wird ja alles auf INFO Level. Gibts eine Option das zu reduzieren?

Idee: alternativ könnte man fürs einzelne Personen-tracking (’…last seen:…’) vielleicht auf DEBUG level gehen, und presence nur bei Bedarf mit einer --debug Option starten.

cheers,
spoocs


#189

Aktuell kannst du den Log über eine Umgebungsvariable deaktivieren. Dazu muss LOG_LEVEL auf NONE gesetzt werden.

Keine schlechte Idee. Gibt es noch weitere Meinungen/Ideen zum Logging?


#190

Wenn es entsprechend dokumentiert ist, sollte das jeder umzustellen hinbekommen - nur das Standard-Logging (so wie es homeean installiert) sollte halt sinnvoll sein (Zielgruppe vs. Speicherbedarf) oder rotated / nach einiger Zeit ggf. gelöscht werden. @spoocs hat da schon einen Punkt, die Speicherkarten der PIs sollten halt auch nicht volllaufen…


#191

Richtig. Dabei ist “volllaufen” allerdings ja nur der eine wichtige Aspekt. Ein anderer ist natürlich, auf SDs zu viele (ggfs. vermeidbare) Schreibzugriffe zu vermeiden - nicht unwichtig für ihre Lebensdauer.
Konkretes presence-Beispiel: bei einem 10s Intervall sind das beim derzeitigen Log-Level pro Monat schon ca. 260.000 Schreibvorgänge, nur fürs ‘last seen’ logging.

Nachtrag: hier übrigens ein interessanter Artikel zum Thema, insbesondere #Tipp 3:

cheers,
spoocs


#192

Gerade deshalb betreibe ich meine pi‘s ausschließlich mit USB -Sticks und wer auf Nummer sicher gehen will, setzt SSD Festplatten ein.


#193

Klar, das muss jeder für sich entscheiden - wie wichtig oder kritisch sein System ist.
Für mich reicht als “auf Nummer sicher gehen” aber schon, wenn ich ein aktuelles Image von der SD parat hab, und eine Ersatz-SD.

cheers,
spoocs


#194
homeean-presence: ble scan error: Could not start scanning, state is unauthorized (not poweredOn)

…das hab ich nach einem RasPi update/upgrade und Neustart nun. Ist da was zu tun?

cheers,
spoocs


#195

@stfnhmplr Eine Frage. Da ich aktuell keinen Wert auf das logging lege, würde ich es auch gerne ausschalten. Mit welchem Befehl kann ich das im PuTTY denn tun? Was gebe ich da genau ein?


#196

In [den meisten] USB Sticks ist doch genau die gleiche Speichertechnologie (FLASH) verbaut wie in SD Karten, warum ist ein Stick dann besser?


#197

Mag sein, es scheint aber ein Unterschied zu geben wenn bei mir die SD-Karten ca. 6Monate halten und ein USB- Stick schon seit 1 1/2 Jahren weiterhin zuverlässig seinen Dienst verrichten.
Wie gesagt, möchte man auf Nummer sicher gehen setzt man eine ssd Festplatte ein.


#198

Ich habe meinen HASSIO-Pi jetzt seit mehr als 1.5 Jahren mit derselben SD am laufen, es mag auch an der Qualität der SDs liegen…


#199

Das ist ein Fehler vom Bluetooth Modul. Schau mal, ob du manuell scannen kannst.

Das kommt darauf an, wie du homeean presence installiert hast und wie du es startest. Das Stichwort „Umgebungsvariablen“ sollte Dir weiterhelfen. Entweder wird es dem Startbefehl voran gestellt oder, im Falle eines Services kann der Wert dort hinzugefügt werden.


#200

Bei einer Standard-Installation auf einem Standard Raspian läuft presence ja als Service. Ich vermute da wäre folgendes das richtige. Auf der Console:

  • sudo systemctl edit --full homeean-presence.service

  • in der Datei fügst Du im Block [Service] als erste Zeile hinzu:
    Environment="LOG_LEVEL=NONE" Dann speichern und schließen.

  • anschließend sudo systemctl restart homeean-presence

Vor dem ganzen kannst du natürlich noch dein presence Logfile löschen. Liegt in:
~/.homeean-presence/

Ich bin mit zwar nicht sicher, ob man damit andere Env-Variablen für den Service überschreibt, aber zumindest läuft presence noch korrekt bei mir. :wink:

cheers,
spoocs