ZigBee-Würfel wird manchmal automatisch kurz entfernt und wieder hinzugefügt

Und mal wieder aus unerklärlichem Gründe wurde der ZigbeeWürfel entfernt… Warum passiert das und nein keiner hat den Würfel umgestoßen oder abgenommen…

2.22 (4067)

könnte eine schlechte elektrische Verbindung zwischen den Würfeln die Ursache dafür sein?

Wenn der ZigBee-Würfel “entfernt” wird, bleibt er dann solange entfernt, bis du ihn abnimmst und wieder aufsetzt? Funktionieren dann solange auch alle ZigBee-Geräte nicht?

Ich würde wetten dass das mit dem Zigbee buffer Problem bei Updates verwandt ist

Hmm, könnte man meinen. Aber ohne irgendeine Veränderung im System?

nein er kam von alleine wieder…und erst danach gingen die Geräte auch wieder…

Und kam er auch mit der Meldung “ZigBee-Würfel hinzugefügt” wieder?

Mmm ja schau hier…

Ich habe mal den Titel angepasst…

Sind das immer nur Sekunden, in denen der Würfel “getrennt” ist, oder dauert das auch mal länger?

aufgrund der neuen Informationen, noch mal meine Frage, könnte es sich um ein Kontaktproblem zwischen den Würfeln handeln

Hallo,

ich will mal versuchen deine Frage zu beantworten.

Dieses Phänomen tritt auf, wenn das Betriebssystem vom homee Brain Cube den ZigBee Würfel neu enumeriert. Dabei wird das Gerät virtuell kurz vom Betriebsystem ausgeworfen und anschließend wieder neu hinzugefügt. Dabei werden die gleichen Events getriggert (Gerät entfernt/ hinzugefügt) wie beim echten abnehmen des Würfels. Deshalb sieht es im Tagebuch auch so aus wie bei dir.

Warum enumeriert das Betriebsystem den Würfel neu?

Das kann, wie so vieles in der IT unzählige Gründe haben und ich kann hier leider nur mutmaßen.

  • Ein Fehler im Treiber bringt das Kernelmodul zum Absturz. Das Gerät würde ausgeworfen werden, da der Treiber ja nicht mehr funktioniert und anschließend neu hinzugefügt werden.

  • Ein Fehler im Betriebsystem sendet fälschlicherweise die Events “Gerät entfernt” / “Gerät hinzugefügt” über den Eventbus. homee würde sich verhalten als wenn der Würfel abgenommen / aufgesetzt wurde.

  • Ein Fehler in der Software des ZigBee Würfels bringt diese zum Absturz. Der Reset-PIN des Moduls würde angesteuert werden, dies führt dazu das das Gerät neu enumeriert wird.

  • Fehlerhafte Kommunikation seitens homee sendet eine Nachricht an den Würfel, welche dessen Software zum Absturz bringt. Die Folgen wären die gleichen wie ein Punkt weiter oben.

  • Eine kurze Spannungsunterversorgung sorgt dafür, dass die benötigte Betriebsspannung für den ZigBee Würfel nicht mehr ausreicht. Die Folge wäre ein Hard Reset des Würfels. Er würde kurz entfernt, und direkt danach wieder hinzugefügt werden.

  • Zu Starke Oberschwingungen in der Versorgungsspannung. Oberschwingungen entstehen durch Betriebsmittel mit nichtlinearer Kennlinie wie etwa Transformatoren, Leuchtstofflampen sowie leistungselektronische Betriebsmittel wie Gleichrichter, Triacs, Thyristoren usw. Zudem entstehen Oberwellen in Schaltnetzteilen in Fernsehgeräten, Computer, Halogenbeleuchtungen usw. Informationstechnischen Betriebsmittel (wie der ZigBee Würfel) sind bei der elektrischen Zulassung durch die Bundesnetzagentur dazu verpflichtet sich in solchen Fällen “definiert” zu verhalten. Eine zugelassene Verhaltensweise ist z.B. ein Neustart. Dieser hätte zufolge das das Gerät in homee entfernt und direkt wieder hinzugefügt wird.

Ich denke die Liste kann durchaus noch etwas länger werden, wenn man noch eine Weile darüber nachdenkt.

Ich denke dies ist wahrscheinlich eher nicht das Problem. Die Pins werden in der Regel gut durch die Magnete gehalten und haben eigentlich noch nie zu Problemen geführt. Ausschließen kann man dies natürlich auch nicht wirklich.

7 „Gefällt mir“

Ich habe das Phänomen wenn ich ein BOS Digitalfunkgerät daneben stelle. Da verabschieden sich alle drei Würfel kurz. Das hat mich auch ein paar graue Haare gekostet bis ich dem auf die Schliche gekommen bin.

2 „Gefällt mir“

Ich bin kein Lötkolben, aber hast du deinen homee vll in einem Mehrfachverteiler stecken, in dem ein anderes Gerät stört? Oder ein von homee unabhängiges Gerät, das zu dem Zeitpunkt der Störung eingeschaltet wurde?

2 „Gefällt mir“

Passend dazu: gutes Netzteil mit mind 1A?

Ich hatte das Problem auch schon mal. Damals habe ich die Kontakte gereinigt/entfettet und alles war wieder gut.

Also einen Versuch ist es immer wert.

Ich hatte das oft mit meinem Z-Wave Würfel. Seit ich die hier im Forum mal vorgeschlagene Mini-USV davor gehängt habe, ist zumindest bei mir Ruhe. Das würde für die schwankende Netzspannung (Schwingungen, Spitzen…) sprechen.


Vorteil von einer USV ist nebenbei noch die (wer hätte es gedacht) UnterbrechungsfreieStromVersorgung bei Stromausfall oder nicht benötigtes Herunterfahren des homee bei Einbau eines neuen 230V Aktors. Oder das Anlernen vor Ort - Homee wird dann portabel :wink:

3 „Gefällt mir“

Habe den hängen, aber der Zigbee Würfel kommt homee nach einem Update auch manchmal abhanden.

1 „Gefällt mir“

Wie kann ich mit der davorgehängten usv homee aus der Ferne Neustarten falls mal nix mehr geht… da hilft ja nur stromlos machen …das habe ich bisher über WLAN STECKDOSE geregelt…das fällt ha dann weg …

Mit Sicherheit dann auch keine Option … leider…

1 „Gefällt mir“

Auch wenn es für dein Problem leider immer noch keine Lösung gibt, ist dies (ZigBee Würfel nach Neustart vermisst) ein anderes Problem und hat mit Sicherheit auch andere Ursachen als das worum es in diesem Thread geht.