WebApp auf mehreren Tablets/Smartphones zeitgleich nutzen

Hallo zusammen,
Seit kurzer Zeit Nutze ich Homee. Ich habe nun 3 Tablets - für jede Etage des Hauses eins. Zudem sind zwei Smartphone im Haushalt vorhanden.

Auf jedem der fünf Geräte ist die Homee WebApp installiert.
Gerne würde ich auf jedem Gerät die WebApp gleichzeitig nutzen können. Jedoch werden immer, sobald ich ein Gerät mit der WebApp nutze, alle anderen Geräte ausgeloggt.

Diverse Ansätze habe ich schon versucht.

  1. Alle Geräte mit dem gleichen Nutzer bedienen - ohne Erfolg
  2. Jedes Gerät mit unterschiedlichem Nutzer bedienen (z.b. Tablet1, Tablett2, Tablet3, Smartphone 1, Smartphone2) - ohne Erfolg
  3. Vorgehen wie in Punkt 2 plus zusätzlich ein Gerät als Hauptgerät mit Chef Homee und jedes weitere mit Homee oder kleiner Homee - ohne Erfolg.

Was habe ich übersehen? Was ist dir Lösung?

Vielen Dank und beste Grüße
Nico

Du kannst definitiv alle Tablets mit dem gleichen Nutzer bedienen. Die Nutzer sollten eh nicht gerätespezifisch sein.

Es liegt also eher an deine Tablets.

Was für eine Fehlermeldung kommt denn, dass du ausgeloggt wirst?

Welche Browser verwendest du?

Hast du irgendwelche speziellen Einstellungen vorgenommen, zB Cookies löschen beim Browser schließen, Incognito Modus in Verwendung, Security Suite im Einsatz etc?

Es kommt folgende Meldung:
Du wurdest von einem anderen Gerät abgemeldet, bitte melde dich erneut an.

Es handelt sich um drei identische Tablets (Lenovo M10). Jedoch tritt der Fehler auch auf den Smartphones auf (Android und Apple).

Im Browser, Google Chrome, habe ich keine Einstellungen geändert. Security software/Virensoftware nutze ich nicht. Die Tablets sind Software technisch Up to Date. Bis auf Philips Hue, Sonos, Home WebApp und fully Kiosk Browser ist nichts zusätzlich installiert.

Kannst du mal auf Einstellungen - Benutzer verwalten - (dein Nutzer) - (ganz unten) Geräte klicken und da dich überall abmelden?

Danach dich dann mit diesem einen Nutzer wieder auf allen 3 Tablets anmelden.

Hoffe, dann klappt wieder alles :slight_smile:

Ich habe es einmal nach deiner Beschreibung durchgeführt. Jedoch hat es erst nach dem 4. Versuch halbwegs geklappt.
Zwei Tablets und Smartphones kommen sich nicht mehr in die Quere. Sobald ich mich mit dem dritten Tablet einlogge, schmeißt es mich bei einem anderen Tablet wieder raus. Das betrifft aber auch immer das gleiche Tablet. Habe darauf überall die WebApp deinstalliert und neu installiert, so wie bei allen drei Tablets die Einstellungen verglichen. Diese stimmen bei allen überein. Auch im Browser ist alles identische :roll_eyes: Das Problem ist danach weiterhin vorhanden.

Wenn du sagst, du hast die WebApp de- und installiert: Was meinst du damit? Du scheinst sie nicht einfach nur im Browser aufzurufen, sondern machst noch was?

Wenn ich die WebApp im Browser öffne, werde ich gefragt, ob ich diese auf meinem Startbildschirm hinzufügen/installieren möchte. Somit wird sie als Schnellstart Icon auf meiner Startseite von Tablet oder Smartphone hinterlegt.

Edit: Wenn Homee direkt im Browser auf allen Tablets genutzt wird, besteht das gleiche Problem.

Hallo, das Problem ist hier vermutlich folgendes: Wir generieren für jede App beim Login eine eindeutige ID, die wir dann als Benutzergerät im homee anlegen. Manchmal kann es allerdings vorkommen, dass zwei Apps die selbe ID generieren, vor allem wenn es die selben Geräte, Browser und Einstellungen sind. Generell machen es einem die Browser hier auch nicht unbedingt leichter, eine eindeutige, reproduzierbare ID zu generieren, da die meist von anderen Webseiten für das Tracking bzw. für Werbung verwendet wird. Wer sich ein wenig einlesen möchte: Wir verwenden hierfür die Library FingerprintJS

2 Like

Gab es da nicht auch mal ein Problem mit dem synchronisieren der Browsereinstellungen?

Danke für eure Infos und Mühen.
Nach ca insgesamt 7 Stunden vergeblichen testens, habe ich den Brain Cube zurück gesetzt und alles neu aufgesetzt. Nun kann ich alle Tablets und Smartphones zeitgleich mit der WebApp nutzen.
Jedoch sollte meiner Meinung nach dies nicht erst durch einen Reset funktionieren. Bisher hatte ich nur einige wenige Lampen und Schalter im Homee integriert. Ich hoffe nur, dass das Problem zukünftig nicht mehr auftritt, vor allem sobald ich noch deutlich mehr Smart Home Geräte verbunden habe.