Community

SFTP Autobackup schlägt fehl


#1

Hallo,

seit meinem Update auf Core 2.22.0 (0bc0f53 rc1) funktioniert mein Autobackup nicht mehr.
Ich habe es durch Zufall im Logbuch gefunden (Push kommt ja nicht :frowning: ).

Unter dem Menüpunkt FTP-Server finde ich folgende Fehlermeldung:
Quote command returned error (21)

Gehe ich nun auf “Testen”, erhalte ich die Meldung:
Test erfolgreich! Du kannst…

Ein manuell angestoßenes Backup auf den FTP Server schlägt ebenfalls fehl.
Ich sichere über eine SFTP Verbindung

Edit: über FTP und FTPS funktioniert es bei mir.


#2

Ich hab das eben überprüft.
V1 mit 2.2.2 macht das Backup
V2 mit 2.2.0, tut es auch.
Beides auf FTP.
:man_shrugging:


#3

Danke für deinen Test. :+1:
Ich habe hier mal meine Einstellungen, eventuell hat ja jemand eine ähnliche Kombination?

Spannend finde ich das die Verbindung zum SFTP Server erfolgreich hergestellt wurde, beim Backup dann jedoch seit dem Update auf 2.22 ein Fehler erzeugt wird.


#4

Das Backup läuft kurz nach Mitternacht
ist dein Laufwerk da verfügbar?


#5

@Kobold ja. Es funktioniert generell nicht mehr seit 2.22 WENN SFTP verwendet wird.


#6

Ich hänge mich mal mit an weil seit dem Update (2.22.0 (0bc0f53 rc1)) habe ich das gleiche Problem.

Homee soll via FTP Protokoll die Daten Ablegen.
Die Auto Backups liefen bis vor dem Update alle erfolgreich durch nur seit dem Update funktionieren die nicht mehr.
Morgens steht bei FTP " Quote command returned error (21)". Wenn ich die Verbindung teste “Test erfolgreich! …”
Manuelles Anstoßen des Backups hat keinen Fehler generiert aber eine Backup Datei wurde nicht in das Verzeichnis abgelegt.
Dieses seit dem Update nicht mehr.

@ducky & @Kobold werden bei euch denn die Backu Dateien angelegt?


#7

Hallo,

nein, auch eine Backupdatei wird nicht erstellt, wenn ich es über SFTP versuche.

Ich denke, dass wir uns nicht groß Gedanken machen müssen und einer der Entwickler den Fehler sehr einfach nachvollziehen kann. Jedenfalls ist das keinen Hoffnung :wink:
Bei mir ist der Fehler jedenfalls super einfach zu reproduzieren und bei dir klingt es ja sehr sehr ähnlich. Freut mich das du den Fehler bestätigen kannst :muscle: (auch wenn es für dich natürlich gerade ebenfalls doof ist :wink:)


#8

Ftp (ohne s) klappt weiterhin


#9

Heute Nacht hat FTP bei mir funktioniert. Auch die Datei wurde erstellt.
Allerdings habe ich jetzt ein anderes Laufwerk als ziehl angegeben welches sich nicht schlafen legt.
Ob es wirklich damit zusammen hängt kann ich nicht sagen da es sonnst mit dem aufwecken unter 2.21 auch funktioniert hat.


#10

Die UTF8 Änderung für FTP Server verhindert jetzt leider den SFTP Export. Das Problem wird mit dem nächsten Update behoben.


#11

Wenn ihr da was ändert…warum steht es nicht in der Release Note? Thomas nutzt sehr oft und entsprechend deutlich den Hinweis das Änderungen in der Release Note stehen und wenn da nichts steht wurde auch nichts verändert (frei, kein wörtliches Zitat).

Ich habe das jetzt nur durch Zufall bemerkt, was in einer Beta ok ist. :muscle: Ein Hinweis für Release Version oder „was soll getestet werden?“ wäre aber sicher hilfreich :wink:


#12

Es steht doch da, der UTF8-Umbau hat (wahrscheinlich mangels Tests) dazu geführt, dass es halt nicht mehr lief…


#13

Du meinst den Hinweis auf die Änderungen beim FTP Export?

Ich würde sagen das kann man gelten lassen und ich habe den Zusammenhang zum Backup nicht ausreichend genug erkannt. :muscle:

Einwand wird zurückgezogen. Danke @hblaschka


#14

SFTP sollte mit der RC2 wieder funktionieren.