Nuki Bridge lässt sich nicht einbinden

Hallo allerseits,

ich hatte in der Vergangenheit bereits erfolgreich meine Nuki Bridge in homee eingebunden. Zwischzeitlich habe ich homee zurückgesetzt / umkonfiguriert sodass nun Nuki bzw. das SmartLock nicht mehr als Gerät auftaucht.

Ich möchte das SmartLock über den bekannten Weg einbinden (IP adresse und Token aus der Bridge). HTTP/API sind in der Bridge aktiv.

Im Browser kann ich mit der IP und dem Token folgenden einfachen Call machen:
http://192.168.178.26:8080/info?token=dqsj3XXX

{"bridgeType": 1, 
"ids": {"hardwareId": 442867994, "serverId": 1203413197}, "versions": {"firmwareVersion": "2.8.0", "wifiFirmwareVersion": "2.2.0"}, "uptime": 13560, "currentTime": "2020-12-29T12:23:22+00:00", "wlanConnected": true, "serverConnected": false, 
"scanResults": [
{"deviceType": 0, "nukiId": 463200092, "name": "Nuki_1B9BDF5C", "rssi": -50, "paired": true}, {"deviceType": 2, "nukiId": 456352786, "name": "Nuki_Opener_1B336412", "rssi": -60, "paired": true}]}

Token und IP sind also offensichtlich korrekt.

Das Einbinden habe ich über die aktuelle Android App auch auch über die Web-App probiert. Erfolglos. Die Meldung lautet immer „Das Einlernen ist fehlgeschlagen, probiere es noch einmal.“.

Gibt es irgendwo eine Möglichkeit etwas bessere logfiles zu bekommen? Zum Beispiel das HTTP-Log?

Viele Grüße
Patrick

Hi,
vielleicht sind alle Callback-URLs in der Nuki schon voll?
Hast du dir das Log der Nuki-Bridge Mal angeschaut?

PS: auch wenn nur lokal erreichbar, würde ich den Token dennoch nicht einfach hier Posten. :wink:

1 Like

@annaeymnd das ist nicht der Originaltoken. Ich habe ihn leicht abgwandelt.

Über diesen call kann ich mir die Logs der Bridge anschauen: http://192.168.178.26:8080/log?count=200&token=dqsj3XXX

Die Meldungen sehen für mich unverdächtig aus. Hast du eine bestimmte Meldung im Sinn auf die ich achten sollte?

nein, hätte da jetzt nichts konkretes im Sinn.

Schau Mal unter /callback/list nach, ob homee(IP) da bereits auftaucht oder ggf alle 3 Slots belegt sind.

kann homee die Bridge erreichen (gleiches Netzwerk) oder ist ggf. eine Firewall dazwischen?

1 Like

Die Nuki Bridge als auch homee sind im gleichen (sub-)netz. Es ist keine Firewall dazwischen.

/callback/list ist leer und zeigt überhaupt keine registrierten callbacks.

Ich habe jetzt nochmal mit /clearlog die logfiles in der Nuki Bridge gelöscht und erneut versucht die Bridge einzubinden. Wieder ohne Erfolg. Es gibt auch keinerlei Meldung im Nuki-log.

Gibt es denn im homee keinerlei logfile/debug log um zumindest mal den Hauch einer Chance zu haben den Fehler zu finden? Wenigstens ein http-log oder Ähnliches? Die Fehlermeldung im Homee ist ja nun ziemlich unpräzise.

@Steffen ?

Hattest du das Nuki schon mal auf Werkseinstellungen zurückgesetzt und ein erneutes Anlernen versucht?

Wenn das auch nicht hilft, sende mir doch bitte mal einen Supportzugang dann sehe ich es mir auch mal Live an.

Danke für eure Hilfe. Es hat doch gezeigt, das der Fehler letztlich doch vor den PC saß🤦

Ich hatte für Nuki und homee ein eigenes virtual WiFi konfiguriert (nur im 2,4 GHz Bereich), da beide Geräte Probleme mit meinem normalen WiFi hatten (Mischbetrieb 2,4 und 5GHz). Offenbar war außerdem noch ein MAC Filter aktiv. Der hat letztlich dafür gesorgt, das homee keinen Kontakt mit der nuki Bridge bekommen hat. Habe den Filter deaktiviert und prompt hat das Einlernen geklappt.

Entschuldigt bitte, dass ich nicht schon viel früher darauf gekommen bin.

1 Like