Community

Neues Herstellen der Verbindung zu Amazon Alexa nicht möglich

Nachdem Alexa bei mir auch für Alexa deaktivierte Geräte ständig neu gefunden hat, habe ich mal die Verbindung zu Alexa getrennt.

Bei den anschließenden Versuchen, die Verbindung wieder herzustellen, gab es immer eine Fehlermeldung: “Das Verknüpfen hat nicht funktioniert. Stelle sicher, dass deine Zugangsdaten richtig sind und dein homee online erreichbar ist.”

Ja, die Zugangsdaten sind korrekt. Ich kann mich damit problemlos in der Web-Oberfläche anmelden.

Ja, homee ist online erreichbar: Am Handy habe ich außerhalb des eigenen WLANs Zugriff auch homee. In den Einstellungen heißt es: “Fernzugriff: Verbunden”.

Das Herstellen der Verbindung habe ich probiert sowohl in der Web-Oberfläche am PC als auch am Handy - jeweils sowohl angestoßen über homee als auch angestoßen über Alexa.

Wie kriege ich wieder eine Verbindung zu Alexa?

Warum wurden ursprünglich in Alexa Geräte gefunden, die in homee für Alexa deaktiviert waren?

Versuch mal den Skill komplett zu löschen und anschließend neue anzulegen. Ich habe für Alexa einen separaten User angelegt. Das soll aber nicht notwendig sein.

Einen separaten Nutzer für Alexa anzulegen ist unnötig. Der Skill nutzt die eingegebenen Verbindungsdaten nur ein einziges Mal während der Verknüpfung.

Skills lassen sich deaktivieren. Das habe ich gemacht. Aktivierung und Konto-Verknüpfung sind dann ein einziger Schritt. Da die Verknüpfung des Skills bisher erfolglos war, bleibt der Skill auch weiterhin deaktiviert.

Eigentlich wollte ich schon “meckern”, dass es hier statt Hilfe für den Ratsuchenden nur Korrektur der anderen Ratgebenden gibt.

Aber ich habe in Deinem Beitrag einen Lösungsansatz entdeckt:
In der Tat hatte ich einen eigenen User mit der Rolle “Kleiner homee” angelegt und diesen für die Verknüpfungsversuche verwendet. Auf Deinen Beitrag hin habe ich jetzt mal den Hauptbenutzer mit der Rolle “Chef homee” verwendet. Nun hat die Verknüpfung geklappt.

Tatsächlich hätte ich das auch selber erkennen können, denn dem “Kleinen homee” fehlt das Recht der Verknüpfung mit Sprachassistenten. Das habe ich jetzt im Nachhinein nachlesen können. Allerdings führt die Fehlermeldung auf eine falsche Spur.

Vorschlag: Die Fehlermeldung anpassen, z.B. “Das Verknüpfen hat nicht funktioniert. Dem verwendeten Benutzer fehlt das Recht zur Verknüpfung mit Sprachassistenten.”

1 Like

Was lässt euch denn darauf schließen dass hierfür ein neuer Benutzer benötigt wird? :thinking:

Das tut uns leid, aber sowas passiert öfter, da Probleme von Ratsuchenden meist unzureichend beschrieben oder schwer zu verstehen sind. Solche Sachverhalte können mit unter nicht “adhoc” gelöst werden. Offensichtliche Fehler oder falsche Ratschläge sind einfach von Natur aus schneller zu behandeln. In deinem Fall: Du hast in deiner Problembeschreibung mit keiner Silbe erwähnt das du einen neuen “kleinen homee” zum Verbinden verwendest. Daher ergäbe sich für dein Problem eine immense Summe an möglichen Problemen, die nicht ohne viel Kommunikation bearbeitet werden können.

Dennoch: Freut mich das du aber dennoch die Lösung zu deinem Problem gefunden hast. :beers:

1 Like

Laienhaft habe ich zunächst gedacht, dass bei jedem Zugriff von Alexa ein Login mit den Benutzerdaten stattfindet. Darum habe ich auch einen Benutzer mit möglichst wenig Zugriffsrechten angelegt. Tatsächlich ist es aber wohl so, dass der Benutzer nur einmal dafür sorgt, dass Alexa ein Token bekommt und mit den benötigten Zugriffsrechten versorgt wird. Und tatsächlich gebe ich die Benutzerdaten ja auch in eine Web-Maske von homee ein. Alexa bekommt die Benutzerdaten gar nicht.

Übrigens ist eine der beiden ursprünglichen Fragen jetzt für mich nicht mehr relevant:

Alexa findet nur noch die Geräte, die ich für Alexa aktiviert habe.

Warum ursprünglich auch deaktivierte Geräte gefunden wurden, das dürfen die homee-Macher nach Belieben klären.

Den Benutzer mit der Rolle “Kleiner homee” hatte ich auch vorher schon in meiner Benutzerliste. Ich habe ihn zur Fehlereingrenzung nur zwischendurch gelöscht. Ob es früher auch “Kleinen homees” möglich war, die Verknüpfung mit Sprachassistenten herzustellen, daran kann ich mich nicht erinnern. Möglicherweise habe ich auch bei Einführung der Verknüpfung zu Sprachassistenten doch mithilfe des “Chef homees” die Verknüpfung hergestellt.