Netatmo Werte verschoben

Ich bin gerade etwas über die Verläufe meiner Netatmo Wetterstation gestolpert.
Welche Zeitstempel werden denn in die Datenbank geschrieben?
Folgender Verlauf der Temperatur (Fenster war vergessen worden :frowning:)

Die Zeiten passen nicht. Hier der Screenshot von der Netatmo Seite

Dieser Verlauf passt.
Bei anderen Geräten ist mir so ein Versatz nicht aufgefallen. Die Zeiten der Haustür etc. passen alle. Daher scheint es kein grundsätzliches Problem sondern speziell mit Netatmo zu sein.

Edit: Tatsächlich hängen die Werte auf der Netatmo Seite aktuell ziemlich hinterher. Es werden aktuell (13:27) die Werte von 12:00 angezeigt. Aber der Verlauf passt mit den Zeitstempeln zu den tatsächlichen Ereignissen.

Warte mal ab, bei Netatmo gibt es wieder einmal Server Probleme. Die Daten in der Netatmo App stimmen bei mir auch nicht und myatmo bekommt die Daten mit zwei Stunden Verspätung. Ich vermute mal das es mit den Daten in homee ähnlich ist.

https://helpcenter.netatmo.com/de

Ja stimmt schon, das hatte ich ja auch festgestellt. Trotzdem stimmen die Zeitstempel nicht im homee.
Es sieht also so aus, als wenn homee den Zeitstempel der Daten nicht berücksichtigt und statt dessen einfach die Uhrzeit des Datenabrufs hernimmt.
myatmo oder die Webseite selber kommen halt damit klar. Daher gehe ich von einem Fehler in homee aus.

Da hast du recht, kann ich bei mir so bestätigen. In homee wird der zuletzt gemeldete Wert mit der aktuellen Zeit versehen.

1 Like

Ist denn sichergestellt, dass mit dem Temperaturwert der Messzeitpunkt überhaupt mitgeliefert wird? Sonst hat homee gar keine andere Möglichkeit, als die aktuelle Zeit zu nehmen.

Fragen wir doch mal @Steffen, der sicher weiß wer die Netatmo-API derzeit betreut…

Aktuell auf der Netatmo-Seite. Bei mir sind die Werte auch nicht korrekt.
Also kein Fehler bei Homee. Einfach abwarten.

https://helpcenter.netatmo.com/de/smarte-wetterstation-und-zubehor/top

Gruß, Jörg.

Es lebe die Cloud :tada:

1 Like

Jepp. Leider oft so bei Netatmo.

Ich bleibe dabei… doch!
myatmo kann es auch. Dort hört das Diagramm dann eben beim neuesten Wert auf.
Wenn keine Aktuellen Werte kommen kennt homee zum Beispiel ausgrauen.
Aber falsche/alte Werte oder Werte zu einem falschen Zeitpunkt ist nicht richtig.

Dann schau mal in deinen Netatmo-Account.
Dort ist bei mir der letzte Wert aktuell von 15:16 Uhr.
Es kommen ja Werte rein, nur halt eben zeitversetzt.
Und warum gibt Netatmo dann so eine Meldung raus?

Das bestreite ich ja alles nicht. Die Api liefert aber keine falschen Werte sondern einfach nur alte. Und wenn keine neuen kommen kann man ja die alten Werte nicht einfach als die aktuellen darstellen. Das ist nur so, wenn die API keinen Zeitstempel an den Daten hat.

Und das hier sind Timestamps in den Measures.

Oder bei den Station Data:

Bei mir werden die Werte aktueller, habe nur noch 23 Minuten Verzögerung. In homee passt es damit so langsam auch wieder.

Es betrifft auch nicht alle User. Habe mal in der Netatmo-Karte geschaut.
Viele Werte sind aktuell.

@danil hat in dem Fall recht! homee übernimmt nicht die Zeitpunkte der Netatmo-API, sondern setzt den Punkt dann wenn er ankommt.
Weshalb das gemacht wurde kann ich nicht sagen, aber ist natürlich ungünstig wenn die Daten derart verzögert gesendet werden.

2 Like

wirds korrigiert? :roll_eyes:

Ich habs auf jeden Fall aufgenommen. Wir schauen uns das morgen mal genauer an :wink:

7 Like