Community

Kein Zugriff auf homee bei gesperrtem Internet


#1

Warum funktioniert der Zugriff auf homee über die lokale Adresse nicht, wenn der Internetzugang im Router gesperrt wird? Ist mir gestern beim Ausfall des Fernzugriffs aufgefallen. Lokale-Seite wird aufgebaut, Anmeldung erfolgt, Geräte, Homeegramme sichtbar aber keinen Status. Immer nur Wiederverbinden.

Version:2.22.2


#2

Das Wetter kommt via Internet.
Was passiert , wenn du das Wetter -Widget herausnimmst?


#3

Das Wetter holt sich aber der Cube und liefert es an das Frontend bei Bedarf. Beim Aufrufen des Frontends , bedarf es daher nicht der Verbindung zum Internet.
Der Fehler wundert mich gerade auch!

Ich bin gerade dabei meinen homee komplett offline, im eigenen Netzwerk zu betreiben. Eingesperrt in ein eigenes VLAN, trotzdem erreichbar über eigenen Internet-Proxy, über seine lokale IP übers VPN. Funktioniert noch nicht wie ich es will, aber der Fehler hier wäre ein NO-GO!


#4

Hast du in der Anmeldemaske die IP-Adresse eingegeben anstelle der homee-ID?
Das war hier schon mal ein Thema. Mit homee-ID geht die WebApp immer über den Proxy, auch lokal.
Viele Grüße, Dieter


#5

In seinem Screenshot ist die lokale IP in der Adresszeile sichtbar.


#6

es ging um den Wert in der Maske, nicht der URL


#7

Ah ok :sweat_smile:


#8

Hi, habe mich natürlich mit der ID angemeldet. Mit IP getestet und alles funktioniert in der WebApp. Nur in der IOs-App funktioniert das mit der IP nicht.


#9

Die iOS App sollte automatisch erkennen, wenn sie sich im lokalen Netz befindet…


#10

Das ist korrekt. Habe ich getestet, wenn ich mit dem iPhone im gleichen WLAN bin funktioniert das. Ich habe eine Routerkaskade und trenne Smarthome, Streaming etc. von den PCs. Anpingen kann ich Homee aus meinem Subnetz. Sobald ich aber das Internet für Homee im Hauptnetz deaktiviere, geht die IOs-App nicht mehr. Aus dem Subnetz erreiche ich den Homee im Hauptnetz dann nur über die WebApp.

Aufbau:
Netzwerkaufbau


#11

OK, das erklärt dann Deine Probleme, die IOS App muss aus dem WLAN natürlich den homee erreichen können, weil sie erst mal scannt ob er vorhanden ist. Ich glaube mich erinnern zu können, dass es dazu schon mal ein oder zwei Threads (teils mit Protokoll- und Portangaben) gab, hab aber jetzt unterwegs nix mehr zu gefunden…


#12

Mit der WebApp funktioniert es ja schon aus dem Subnetz, nur die IOs-App verweigert die Verbindung. Der homee ist aus dem Subnetz erreichbar.


#13

Nun das kann verschiedene Ursachen haben. Die Web App kennt die genaue IP Adresse deines homees, da du sie ja angibst. Die iOS App hingegen macht in deinem Netzwerk einen Broadcast, um somit den homee zu finden. Meistens werden Subnetze gebildet, damit eben so ein Broadcast nicht an alle Geräte geht. Daher wird dein Broadcast vermutlich nicht in das Subnetz weitergeleitet, in welchem dein homee ist. Du könntest eventuell eine Art “Brücke” einrichten, damit der Broadcast weitergeleitet wird.