Community

homee in Verbindung mit MQTT: homeeToMqtt


#41

Hab ich gestern mal geschaut aber da ist leider invite only oder ?


#42

Habe dir ne PN geschrieben



#43

Fast eine Woche spÀter, die Verbindung ist immer noch stabil und Homee nicht stehengeblieben. Kein Neustart oder Àhnliches notwendig. Gateway lÀuft somit immer noch einwandfrei.

Der Homee ist jetzt nur noch verdummt zu einer MQTT <-> Zwave Bridge. Die Workflows wurden alle in Node-Red umgesetzt. Sobald die Xiaomi Sensoren geliefert wurden, wird alles zu Zigbee (deCONZ) und Wifi+MQTT migriert.

Was soll ich sagen, wunschlos glĂŒcklich. Auch Gruppen mit 10 GerĂ€ten schalten jetzt immer so wie sie sollen. Da soll einer sagen, es liegt nicht an Homee
 Das ZigBee Mesh arbeitet jetzt wie es soll.

Ich bedanke mich recht herzlich, denn das Plugin hat es ermöglich in fast zwei Wochen von >100 Homeegrammen auf Node-Red mit unzĂ€hligen Workflows zu migrieren, ohne dass die Automatisierung zwischenzeitlich nicht verfĂŒgbar war.


#44

Mega Workaround. Sehr reizvoll die ganze Geschichte. Da ich sowieso einen Teil meiner Automation auf Node Red laufen haben werde ich das wohl mal testen.

Verstehe ich das richtig, dass mqtt dann nur in Richtung Raspberry geht. Also schaltest du die Aktoren im Node Red ĂŒber webhooks?

Vielen Dank


#45

Der Adapter geht in beide Richtungen. Man kann auch mit Mqtt homee GerÀte schalten.
Direkt ohne webhook


#46

Kann mich nur anschließen!!! Super genial das Ganze und seit es in Io Broker lĂ€uft TOP TOP TOP


#47

Ich habe es getestet.

Die Installation habe ich per homeeanscript von @stfnhmplr durchgefĂŒhrt. Hat auch auf einem nicht mehr JungfrĂ€ulichen Raspi3 perfekt funktioniert.

Dann habe ich das Beispiel von @gido in Beitrag #25 in Node-Red importiert und konfiguriert.

“Flow zum loggen aller eingehenden MQTT Nachrichten”

Es funktioniert soweit und die StatusÀnderungen werden im Debug angezeigt.

Leider werden aber auch alle meine Rollershutter alle 3 Minuten angesteuert. Dieses Verhalten konnte ich erst abstellen als ich den Nutzer mqtt auf dem homee gelöscht habe. :disappointed_relieved:

Hat dazu jemand eine Idee? Nutzt noch jemand diesen Server mit Rollershuttern?


#49

Ja ich. Welche Roller Shutter hast du denn?
Was ist alles noch von Homebanking eingerichtet?
Gibt es noch andere eingerichtete flows mit MQTT?
Logfile vo homeeToMqtt?
Genug der Standardsupportanragen. Es gibt folgende Vermutungen.
homeeToMqtt fragt in der Standardkonfiguration alle 3 Minuten den Status der homee ab. Das lĂ€sst sich per Config.json abschalten, da man diese Funktion fĂŒr reines Datenbanklogging ja nicht braucht. So wie du es beschreibst greifst du ja nur lesend auf die homee zu. Da sollte sich Nix schalten aber um sicher zu gehen kannst du ja auch mal subscribe auf false setzen. Dann kann homeeToMqtt garnicht schalten.
Hasst du außer schreibe alles in eine eine Datenbank noch andere flows aktiv die nach MQTT senden?
Oder iobroker laufen mit Mqtt Plugin eingerichtet?
Man kann ja auch via MQTT steuern. HomeeToMqtt schreibt ja auch ein Logfile. Dort wĂŒrde man eingehende Steuerkommandos auch sehen.
Wie eingangs gesagt eine VerknĂŒpfung mehrerer Dienste via MQTT isr kein einfaches Unternehmen, es haben aber auch schon viele geschafft also nur Mut und Logs lesen dann klappst auch.


#50

Alles klar ich checke mal die Logs nach „Schreibzugriffen“.

Ich habe lediglich diesen ein Flow aktiv.

Hatte ihn dann deaktiviert und das Verhalten war noch existent.


#51

homeeToMqtt wĂŒrde ja weiterhin seine Status alle 3 Minuten pushen.
Ändere doch mal folgende Werte in der config.json ab. Diese passen auf deine derzeitige Konfiguration. Bei der Einstellung Human werden die MQTT Topics in einer anderen Art und Weise aufgebaut die hervorragend zu IOBroker passt gesendet. Diese brauchst du aber wohl nicht. Da aber human die eigenen gesendeten Nachrichten selber scubscribed könnte es theoretisch sein das deine Rollershutter wie ein Trigger darauf reagieren. Wenn du folgene config.jason Werte Ă€nderst sollte der Spuk dann auf jeden Fall vorbei sein.

"publishHuman": false,        
"publishInt": false,
"publishBool": false,
"subscribe": true,
"subscribeHuman": false,
"homeeStatusRepeat": false,

Schreib doch nochmal welche Rollershutter du verwendest.


#52

Vielen Dank.

Ich versuche das nachher mal.

Fibaro Roller Shutter 2.


#53

hmm

Habe ich auch.


#54

Verdummt ihr jetzt alle die homees?
Ganz schön teurer zwave Stick dann :joy:


#55

Der Spuk ist jetzt tatsÀchlich vorbei.

Gibt es jetzt aber noch ne Möglichkeit die GerĂ€te-IDs auszulesen oder muss ich dafĂŒr die config.json erst wieder Ă€ndern?

Wenn ich nur aber doch den Status einiger GerĂ€te auslesen muss. Welche Parameter wĂŒrdest du in der Config erstmal aktivieren um den “Spuk” auszuschließen?


#56

Den Großteil lasse ich schon noch auf homee. Nur die Sachen die er nicht kann ziehen auf Node-Red um.

Anwesenheitssimulation, besseres Alexa, HomeKit, Anwesenheitserkennung und Sheduler.


#57

Ich glaube das hat was mit den Einstellungen auf deinem mqtt Server zu tun. Das gleiche hatte ich bei iobroker am Anfang auch dann habe ich geĂ€ndert das weder bei Subscribe noch bei Connection die Werte zurĂŒckgegeben werden sondern nur bei Änderung


#58

Kann damit leider nicht so viel anfangen. Kannst du da bitte mal nÀher darauf eingehen. Arbeite nur mit nodered.


#59

Hast du in nodered nen mqtt Server ?


#60

Nutze mosquitto aus homeean und die nodered mqtt nodes


#61

Artikel dazu in der aktuellen ix.