Community

Homee in homee Zugansdaten falsch (Node RED)

Hallo zusammen,

trotz Suche und Beschreibung hier (homee community & auch in Google) bekomme ich ein virtuellen homee nicht zum laufen.

Die homee Api ist installiert, läuft und gibt auch Debugnachrichten raus!

Ich habe versucht nach der Instarerläuterung umzusetzen (https://wiki.instar.de/Software/Andere_Plattform/Homee_und_Node-RED/), jedoch ohne Erfolg.

Hat oder kann mir dazu jemand helfen? Liegt es vielleicht daran, dass Node Red im Docker= Portainer läuft!?

Danke.

VG

BLRD

Welchen Netzwerkmodus verwendest du denn für den Node-RED Container? Versuchs mal mit Host und lass den gebundenen Port weg.

Hallo Stefan,
hallo zusammen,

der Netzwermodus ist der Bridgemodus.

Was jedoch im in Node Red funktioniert ist, dass der richtige homee verbunden ist!?
grafik

Danke für die Hilfe.

VG

BLRD

Stell ihn wie gesagt mal auf Host um. Die Richtung Container -> Extern hat nichts mit den Portbindings zu tun, daher läuft der Api-Node.
Für den virtuellen homee wird ja ein zusätzlicher Port benötigt. Im Host Modus verwendet der Container das gleiche Netzwerk wie der Host. Da sollte es dann keine Probleme geben.

Hi Stefan,

Danke für die Antwort. Bin leider etwas zur Zeit überfragt wie ich diese Ganze in den Host-Modus bekomme!?

Gibt es dazu Ableitungen!?

Danke.

BLRD

Da Du anscheinend Portainer nutzt werde ich es mal dafür erklären.

  1. Rufe Portainer im Browser auf.
  2. Wähle links im Menü „Containers“.
  3. Klicke auf deinen iobroker Container.
  4. Wähle „Duplicate/Edit“ unter „Actions“
  5. Runtersrcollen zu „Advanced container settings“ und auf „Network“ klicken
  6. Im Drop-Down-Menü Namens Network „host“ auswählen.
  7. Auf „Deploy the Container“ klicken.
  8. Etwaige Warnung bestätigen. Fertig.

Hi Karate-Tommy,

Danke für die Rückmeldung.

Habe dies auch so umgesetzt und es funktioniert auch so, zumindestens mit einer erfolgreichen Rückmeldung im Portainer.

Allerdings bekomme ich dies über den Browser (mit 127.0.0.1:XXX) nicht zum laufen und bin zurück auf die Bridge.

Danke.

Noch eine Idee.

VG

Leider fehlen mir ein paar Informationen zu deiner Konstellation, daher kann ich nur vermuten, dass du einen Laptop oder PC nutzt und die 127.0.0.1:8081 einfach im Browser aufgerufen hast. Das wird nicht funktionieren, wenn iobroker auf deinem NAS läuft. Die IP ist für den localhost reserviert, was eben der PC ist wenn du es vom PC aus aufrufst. Es sollte aber funktionieren, wenn du 127.0.0.1 durch die IP-Adresse des NAS ersetzt.

Also so wie oben beschrieben in den host-modus und dann mit ip:port im Browser aufrufen.

Hi Karate-Tommy,

ja war es zu kurz und blöd beschrieben.

Auch mit der IP des NAS geht es leider auch nicht.


grafik
grafik

Danke.

BLRD

Du bekommst also im Netzwerk Modus Host und Aufruf von http://ip-adresse-des-nas:1880 keine Verbindung? Dann stimmt da vermutlich etwas anders nicht.
Was du im Bridge Modus machen kannst:
Im Reiter „Port-Einstellungen“ der Container-Settings (rechte Maustaste - bearbeiten auswählen) kannst du die Ports mappen. Mit

- 1880:1880
- 7681:7681
- 15263:15263 (udp)

sollte es dann im Bridge Modus funktionieren. Habs lokal getestet und konnte den virtuellen homee so verbinden.

Hi Stefan,

dass werde ich morgen probieren und eine Rückmledung geben.

Danke!!!