Community

Hilfe für Webhook


#1

Den folgenden CGII-Befehl möchte ich in eine Webhook einbinden:
GET: http://192.xxx.xxx.xx///param.cgi?cmd=setioattr&-io_enable=1&-io_flag=1

Die Befehlszeile konnte ich mit dem gewünschten Resultat per Browswer abschicken. Der HG-Test verlief Fehlerfrei. Das HG erzeugte aber nicht die Aktivität.

Kann mir jemand sagen, was ich ändern muß?


#2

Kann homee überhaupt etwas mit Parametern anfangen?
Ich habe schon mehrfach versucht Temperaturen per JSON oder anderen Variablen an homee zu schicken.
Ich hab es nie hin bekommen.


#3

Nein homee kann mit Parametern nichts anfangen. Dazu müsste es Variablen geben, die zur Auswertung dienen.


#4

@Crunchie, möchte doch einen Webhook von homee absenden und nicht an homee senden, oder nicht?


#5

Hab ich genau anders herum verstanden. Er hat den Hook per Browser abgefeuert, aber homee hat die Parameter nicht berücksichtigt.


#6

Ich schließe das aus dieser Äußerung:


#7

@Crunchie kannst du nochmal genauer erläutern, was du schickst und wie (vlt bild vom Homeegramm) und was du mit Resultat meinst?


#8

Ich möchte eine Instarkamera über homee scharfschalten, wenn der Status auf ‚Abwesend‘ gesetzt wird. Wenn ich die cgi-Zeile im Browser meines iPad eingebe, funktioniert das.


#9

Lade bitte einen Screenshot des HGs hoch, sonst können wir den Fehler nicht finden.

Meine Vermutung ist, dass Du entweder bei der Methode nicht Get ausgewählt hast oder Du über einen Bug gestolpert bist, weshalb ich HGs mit Webhooks eigentlich nur in der WebApp erstelle und im Zweifel lieber noch mal lösche und neu anlege.

Das sollte dann so aussehen:

Auslöser
Wenn Modus auf Abwesend geschalten wird

Aktion
Webhook mit Deiner URL, Methode Get, den Rest brauchst Du nicht zu editieren (da Du ja REST und kein JSOn benutzt).

Probier es so noch mal neu in der WebApp anzulegen und lass uns wissen ob es klappt… Ich bin da auch schon mehr als einmal über komische Phänomene gestolpert und mach das deshalb nur noch mit der WebApp.

Dasselbe dann noch mal für dem Auslöser wenn Modus auf zuhause gesetzt wird (mit entsprechend passender URL fürs Aussxhalten) und es sollte klappen.


#10

Aufruf WebApp ist im Browser mit
http://[ip-Adresse homee aus rooter]:768/webapp ?

Seite kommt leide nicht.


#11

:7681 - nicht :768!

Du kannst auch die normale WebApp (my.hom.ee bzw. beta.hom.ee, wenn Du die aktuelle Beta installiert haben solltest) nutzen.


#13

Sorry, war ein Kopierfehler: Für den Aufruf der WebApp verwende ich
http://[ip-Adresse homee aus rooter]:7681/webapp . Ist das so richtig? Bei mir erscheint die Seite nicht.


#14

Lass uns das Peoblem hinterher angehen. klappt es mit der normalen WebApp den Get-Webhook abzusetzen, oder nicht?


#15

Irgendwie kann ich die WebApp Seite nicht aufrufen.
Wenn ich aber im Browser die Befehlszeile mit IP-Adresse eingebe, wird die Alarmfunktion der Kamera aktiviert.


#16

HTTP://my.hom.ee geht nicht?


#17

Über my.hom.ee konnte ich nun die Webhook per Get anlegen

Bei ‘Aktion testen’ wird die Alarmfunktion der Kamera leider nicht aktiviert.


#18

Und wenn Du den Modus manuell auf Abwesend setzt?


#19

Alarmfunktion wird nicht aktiviert.


#20

homee ist Lokal nicht zu erreichen nur Remote.
Webhook ist an eine lokale IP-Adresse gerichtet und funktioniert in Webbrowser Lokal auch. Es scheint so als homee mit deinen lokal im Netzwerk verbunden Geräten nicht kommunizieren könnte.
Wie sieht den deine Heimnetzwerk Konfiguration aus?


#21

Welchen Parameter meinst Du?
Ich habe schon erfolgreich webhooks an homewizzard abgesetzt.