Errors: "Wifi not in list"+other errors after upgrade (solution)

Hi all, seems this topic pops up on the threads from time to time starting from 2018: e.g:

  • /t/brain-stuck-after-fw-update-return-exchange-request/13210,
  • /t/homee-findet-kein-wlan/32748

Finally, this issue hit me as well on BrainCube v2 in 2024 (I made a firmware upgrade from version 2.40.0 to 2.40.1 using cubeBrain web interface (not through the USB). Basically, I did not realise that device wifi module has „bricked“ (probably, here in this context more correct word gonna be „cubed“ :smile:) after the upgrade, because device itself kept running automations. Only after 1 Week when i realised that i need to change some automations, then i realised that i have problems.

Actually, issue was not trivial at all - device become super buggy: router was reporting that brainCube is connected through the Wifi with strong signal, BUT on attempts to login from mobApp : after 1-2 seconds after login app was loosing the connection „Connection lost“ error, then it reconnects and looses it again: cycle repeats forever without success (except for it successfully burns battery of my mobile phone).

On the attempt to authorise from the Web client i was automatically de-authorised in few seconds after successful authorisation with message „You’ve logged out from another device - please log in again“.

For lazy to read (solution):

for me helped upgrading of the brainCube through the USB (wp-content/uploads/2020/07/homee-USB-Update_EN.pdf ) and i used older version, which worked fine before upgrade.


  • never upgrade even „patch“ versions without making dumps!
  • when cube unstable, try to upgrade using USB again

Complete troubleshooting guide with different attempts and errors:

Ok, I assumed that maybe during the upgrade i got corrupted users storage or issues related to it. No problem, i decided to erase users: wp-content/uploads/2020/07/user-reset_EN.pdf , which is i managed to make only from second or even third attempt. BUT after new user creation, i still could not use it, i kept receiving the same errors both from mobApp and web client.

At this moment i assumed that maybe issue in the Wifi module or how software works with it because i got a feeling that Cube looses connectivity (plus mobApp was exactly showing connection/connection lost). To check it I’ve opened a router logs and dig into the logs from device. No issues from router point of view: router does not report that remote host looses connection/reconnects. Tried to reboot the cube by unplug it, immediately have seen in the router entry that brainCube is disconnected and after few seconds it has re-connected again and does not loose anymore connections. So ok, seems I am on the right direction and checking correct devices, plus router confirmed that seems cube is in the network and has a good signal. Plus LED on the BrainCube is „green“, which also confirms logs from router.

Decided to contact support team and thanks to the guys, they replied very fast with recommendation to reset Wifi. wp-content/uploads/2020/07/WiFi-reset_EN.pdf
Tried to reset and here on attempt to finish reset and reconnect to wifi, i received error „Wifi not in list“, means that seems guys from support were right and issue related to wifi. Likely, I have few routers at home working in different modes and having different AccessPoints (2.4Ghz/5Ghz in different channels).
BUT on the other side, Cube’s open wifi endpoint with name „homee-xxxxxxxx“ is accessible and worked, means that at least i have no hardware problem. On the other side, Cube can not connect anymore to the same AccessPoint, where it was connected before reset of the Wifi. Plus on the top, it does not see any AccessPoints at all, and LED is orange (means that reset of Wifi worked and now it can not re-connect anymore and connection needs to be updated)

As were listed in some threads regarding the „Wifi not in list“, plus based on my knowledge about network devices troubleshooting :

  • decouple WLAN SSID running on 2.4GHz from 5GHz to be sure → done, did not help
  • ensured that AccessPoint runs on 20/40MHz channel bandwidth → done, did not help
  • Use only standard control channel in AccessPoint → done, I moved from „Auto“ to „6“ (mid of the Wifi range) and set Wifi AccessPoints to max signal to force other routers in surroundings/neighbourhood to switch to other channel, did not help
  • do not forget to restart the CubeWifi endpoint (it checks for available AccessPoints only on restart) → done, was always restarting after ANY manipulations with access points
  • enabled DHCP in the router and disabled MAC filtering (just in case if MAC address of the BrainCube regenerated by software on upgrade or so) → did not help, router does not report on any attempts to access access points and no probes happened

Then found in one thread, that was recommended to perform a „factory reset“. Well factory reset always can make things worse, because in my case Cube was still executing the automations, except for I could not change anything anymore and could not control it. But automations and remote controls connected to cube worked fine (still). Factory reset on the other side could mean that i can re-establish connection to BrainCube and will be able to re-install automations and control it again.

Anyways, decided to try to make a factory reset: this was a mistake - device become a real „brick“, because when you start, it wants you to create a new user and configure Wifi, but on the step with wifi endpoint config it fails with „connect to Wifi endpoints“ it still tells „Wifi not in list“ (nothing changed here). So I managed to make things even worse: initially i had things at least working partially, but could not change automations, afterwards I’ve lost all the automations and got really useless pieces of plastic. Actually, I was badly surprised that you can not dump cube configs when you connected to Cube through its open wifi endpoint (e.g in some routers you can still control them if you have admin passwords, etc).

Nevertheless, feeling that its a pure software problem and I have already nothing to loose, decided to make an upgrade of the firmware using USB: wp-content/uploads/2020/07/homee-USB-Update_EN.pdf

And this one worked. Afterwards Brain cube managed to detect Wifi endpoints again. Of course because of factory reset, i have to recreate all the automations… I assume issue was that software was installed incorrectly or contained bugs (after check of the downloads page, i did not see anymore version 2.40.1 and i used older version 2.40.0 instead)

have fun with your automations and do not forget to make backups :smiley:

PS, because new users can not add more than 2 links, i removed first parts in the urls, but you always can google those urls). Also new users can not add images, otherwise could just add some print screens with errors :slight_smile:

@moderatoren IMO, but 2 urls (including urls to your own domains) + 1 image upload is rather a protection from human than from bots :wink: we’re in 2024, If someone decides to mess up the community, then they would produce new accounts rather than add all things into one message.