Community

Eigenen Server für die Zeitsynchronisation wählen


#1

Was willst du damit machen?

Ich habe immer wieder Probleme mit Zeitabweichungen von homee und dem Rest meines Systems. Gerade im Offlinebetrieb.
Das kann schon mal zu Verwirrungen führen, da die Zeiten pro Tag/Neustart mehrere Minuten auseinander gehen. Außerdem werden dann die Verläufe nicht mehr ordentlich aktualisiert…
Ich würde mich freuen wenn ich meinen Zeitserver selber wählen könnte und den der Fritzbox nehmen könnte, dann hätten alle Geräte im SmartHome die exakt gleiche Zeit…

Warum interessiert es nicht nur dich?

Keine Ahnung :smiley: Wer es benötigt weiß schon was ich meine :wink:
Sicher ist euch schon mal aufgefallen, daß das aktualisieren der Verläufe ewig dauert oder nur funktioniert wenn man zwischendurch auf ein anderes Gerät klickt… Das kann ich reproduzierbar auf die unterschiedliche Zeit zwischen homee und System schieben…

Viele Grüße
JayJay


#2

Hallo @JayJayX,

Ich habe mal mein Like gegeben, da ich grundsätzlich gerne die Möglichkeit hätte, die Netzwerk-Einstellungen manuell zu machen.

Aber zu Deinem Problem: der ntp-Server kann doch über DHCP an die Clients übermittelt werden. Bei mir klappt das auch. D.h. bei Dir sendet entweder die Fritzbox den ntp-Server nicht mit, oder homee verwendet den Eintrag nicht (oder beides). Wäre interessant zu wissen, woran das liegt.
Viele Grüße, Dieter


#3

Hey @shamrock,

Kann er das? Kannst Du mir verraten wo ich das einstellen kann? Bisher habe ich das immer in jedem Client Gerät eingegeben.
Wenn homee das nicht könnte, würde es bei Dir ja nicht funktionieren, oder? Also muß es an der FB liegen…

Edit: Hab grad nochmal geschaut, ich kann nur “FRITZ!Box als Zeitserver im Heimnetz bereitstellen” aktivieren… Einstellen kann ich dort nichts weiter…

Viele Grüße
JayJay


#4

Das ist option 42 in einem echten dhcp–server.
Glaube die fb unterstützt nicht andere Server als Sie selbst anzugeben…


#5

Hallo @JayJayX,

Ich habe auch mal etwas gegoogelt, anscheinend machen beide das nicht. Die Fritzbox gibt den ntp-Server nicht weiter (Option 42, wie @zaphod richtig geschrieben hat), homee verwendet den aber anscheinend auch nicht.

Siehe hier:
NTP-Server konfigurierbar oder mindestens vom DHCP

Ich kann es bei mir gerade nicht prüfen, da ich unterwegs bin und auf nicht auf meinen Router schauen kann (ob homee eine Session zu einem ntp-Server im Internet aufbaut). Ich verwende übrigens keine Fritzbox als Router, deshalb schickt mein DHCP-Server die Option 42 an die Clients.

Viele Grüße, Dieter


#6

Ich habe jetzt doch mal schnell nachgeschaut, mein homee baut tatsächlich regelmäßig über Port 123 (=ntp) eine Verbindung ins Internet auf, d.h. er nutzt nicht die Option 42 von DHCP, dann würde er das nämlich nicht tun.


#7

Hi,

wenn “unechte” Server im Router, den die meisten ja haben werden das nicht unterstützen, dann finde ich es um so wichtiger das man das wenigsten, wie bei allen anderen Geräten auch üblich, manuell eingeben kann…

Viele Grüße
JayJay


#8

Ich hab ne sophos firewall die auch dhcp und ntp server ist in meinem Netz aber homee nimmt den ntp nicht sondern einen eigenen…


#9

Wenn man aber auf mit Systemzeit synchronisieren klickt, hat man die richtige Systemzeit…
Wo nimmt homee die denn dann her? Aus der App?

Kann man diese Anfragen von homee irgendwie umleiten auf den eigenen Server?

Viele Grüße
JayJay


#10

Absolut richtig. Alternativ die Nutzung des Eintrags vom DHCP-Server (geht dann allerdings bei einer Fritzbox nicht), wie von @JensHol vorgeschlagen :wink:


#11

So habe ich es gelöst Jay, aber ich habe zwischen homee und der Fritz auch nen Linux Server. Hab der firewall nen rerouting Teil verpasst. NTP Anfragen sind ja genormt.


#12

Leute ich bin kein Netzwerkprofi, nicht mal ein Amateur :wink:

In der Regel gibt man in den Client Geräten doch einfach den gewünschten Zeitserver ein und dann ist’s gut, mehr möchte ich doch in homee auch nicht.

Ok, so rein über die Fritzbox geht dann wohl nicht :frowning:

Viele Grüße
JayJay


#13

Ja, daher mein Vorschlag / request. Entweder Übernahme vom dhcp (dann holt er in den meisten Netzen automatisch, zb hinter ner fritzbox) oder manuell in den Einstellungen. :slight_smile:

Ich wollte nur kundtun, wie mein workaround aussieht;)


#14

Also kann die Fritzbox das doch, nur homee (wieder mal :wink: ) nicht?

Find ich auch cool, nur wäre das ein wenig übertrieben, da jetzt einen Linux-Server nur für die Zeitabfrage zwischen zu schalten… :wink:

Viele Grüße
JayJay


#15

Ich hab den halt :slight_smile:


#16

Schon klar, ich leider nicht :cry:

Aber rein interessehalber… Der homee läuft nur über Deinen Linuxserver und von da dann an die Fritzbox? In dem Linuxserver verbiegst Du die Anfragen von homee an die Fritzbox? Würde das auch über einen Raspi gehen? :smiley:

Viele Grüße
JayJay


#17

Hallo @JayJayX,

In der Doku von AVM habe ich an mehreren Stellen Einträge gefunden, wie die Fritzbox manuell im Client als ntp-Server eingetragen wird, aber nirgendwo eine Info, dass dies automatisch über DHCP passiert. Deshalb bin ich davon ausgegangen, dass dies nicht über DHCP funktioniert. Die Annahme kann aber auch falsch sein. Und ich kann es nicht testen, ich setze die Fritzbox nicht als Router ein.

Viele Grüße, Dieter


#18

Welches Betriebssystem hat dein raspi? Wenn der zwischen Netz und der Fritz hängt und Linux hat, sollte das gehen.
Voraussetzung ist halt dass das Routing durch den raspi geht. (Was ich allerdings kaum glaube :wink:

Www<->Fritz<->Raspi<->Lan inkl. Homee


#19

Moin,

ne, der hängt an der Fritz wie alle Anderen auch… Noobs ist da drauf.

Viele Grüße
JayJay


#20

Dann gehen die Zeit Anfragen direkt über deine Fritz und du kannst das nicht :wink: