Community

Bewegungssteuerung mit FMS

Hallo,
Vllt habt ihr eine Idee.
Ich habe eine Bewegungssteuerung für ein Licht gebastelt.
Allerdings funktioniert es nicht 100% zuverlässig.
Ich möchte, dass das Licht angeht sobald Bewegung da ist. Es soll auch nicht ausschalten, solange Bewegung da ist. Erst wenn wirklich keine Bewegung mehr ist soll es sich nach 1 Minute ausschalten.
Das habe ich mit folgenden zwei HG realisiert. Leider bleibt das Licht doch noch häufig an.

Du hast keine Bedingung, die auftritt, wenn der BWM keine Bewegung mehr erkennt. So wird die Lampe nur ausgeschaltet, wenn keiner mehr im Raum ist. Ist nach 61 Sekunden noch jemand im Raum, dann bleibt das Licht einfach an.
Ich empfehle Dir folgende Änderung am 2. HG:

  • Wenn BWM keine Bewegung meldet schalte Licht nach 61 Sekunden aus.

  • Ändere die Und-Bedingung in “Beim Auslösen und Ausführen”. Das müsste so funktionieren. In diesem Fall sollte aber der Bewegungsalarm auf maximal 30 Sekunden eingestellt sein, um die “Totzeit” (Die Zeit, die der BWM keine Änderung des Zustands erkennt) zu überbrücken. Ich habe bei meinem BWM 2 Minuten Bewegung eingestellt und das Licht wird nach 2 Minuten 21 Sekunden ausgeschaltet.

Ich habe das mit einem Neo Coolcam so gelöst:

HG zum einschalten

Wenn BWM Bewegung meldet
Dann Lampe ein
und
HG für Lampe Aus stoppen

HG zum ausschalten
Wenn BWM keine Bewegung meldet
Dann Lampe aus

Funktioniert zu 99%

So sieht es bei mir aus.

Die Helligkeit der LED-Stripes setze ich auf 95%, um einen vom manuellen Schalten unabhängigen Zustand festzulegen.
So schaltet das HG2 nur ab, wenn die Helligkeit der LED-Stripes vorher auf 95% gesetzt wurde.
Wurden die Stripes also manuell eingeschaltet, dann haben sie 100% und werden dann auch angelassen.

Die Aktion ist auf 3sek. verschoben, damit nicht jedes Drehen im Bett das HG zu einer Aktion veranlasst.
Anders gesagt:
Der Bewegunsgmelder stellt Bewegung fest, und löst nach 3 Sekunden aus, prüft dabei aber nochmals ob immer noch eine Bewegung vorliegt.

  • Vorteil: Nicht jedes Drehen im Bett schaltet die LED-Stripes ein
  • Nachteil: Wenn man das Zimmer betritt dauert es 3 Sekunden bis die LED-Stripes einschalten.

Grüße
klauswerner

Wieso wird sowas immer wieder gefragt statt mal die Suche zu verwenden?

Bewegungsalarmzeit auf 10 Sekunden stellen

HG:

Wenn Bewegung
Dann Licht ein
Dann Licht aus nach 60 Sekunden

Jede Bewegung triggert das HG neu, es bleibt also so lange an, bis die letzte erkannte Bewegung 1 Minute zurückliegt. Erst dann (und nur dann) geht das Licht aus.

So einfach funktioniert das nicht. Wen der BWM ständige Bewegung erkennt, hat er keinen Auslöser für eine NEUE Bewegung. Das Licht wird einfach ausgeschaltet, obwohl noch Bewegung vorhanden ist (habe ich eben getestet). Nach meiner Erfahrung sind auf jeden Fall zwei HGs erforderlich: Eines, das aktiviert wird, wenn neue Bewegung erkannt wird und eines, das aktiviert wird, wenn keine Bewegung erkannt wird.

Beim Fibaro, einem Bewegungsmelder, wird jede Bewegung neu übermittelt. Ein HG langt.

Du meinst einen Präsenzmelder, der für sich selber immer weiter Bewegung erkennt aber nicht jedesmal überträgt.

Nachtrag:
Ebenfalls wichtig ist es, die Alarmzeit auf den niedrigsten Wert zu stellen. Wenn da 3 Minuten drinnen steht, würde eine neue Bewegung frühestens nach 3 Minuten 1 Sekunde erkannt. Eine Übertragung eines geänderten Wertes erfolgt aber nur zur Aufwachzeit des Sensors respektive, wenn man ihn von Hand aufweckt.

Ich habe eben mit Nodon und mit Fibaro getestet (Bewegungszeit auf 30 Sekunden)
Wenn Bewegung
Dann Licht einschalten
und nach 51 Sekunden ausschalten

Beide BWM haben das Licht ausgeschaltet, obwohl ständig Bewegung vorhanden war.
Ich lasse mich gerne eines Besseren belehren. Dann poste doch bitte einmal deine Einstellungen, die funktionieren.

Funktioniert erste Sahne. Solange Bewegung, solange an. Nach letzter Bewegung dauert es 45 Sekunden, dann ist das Licht aus.

Hab ich an mehreren Stellen nach dem Prinzip im Einsatz.

Das ist meine Testeinstellung, die nicht funktionieren:


Ich kann es mir nur erklären, dass du einen anderen BWM hast, der nach dem Ablauf der Bewegungsmeldung eine neue Bewegung erkennt, sofern sie noch vorhanden ist.

Fibaro (um den geht es beim Threadersteller) und Aoetec.
Schau mal bei deinem ob du ihn als Bewegungs (nicht Präsenz)melder einstellen kannst und weniger als die 30 Sekunden.

Denn nach der Alarmzeit (bei dir 30 Sekunden) gibt es noch eine Todzeit (beim Fibaro 1-2 Sekunden), die man noch draufrechnen muss. Das wird bei dir ziemlich knapp: 30 Sekunden + Todzeit - du müsstest danach zappeln, dass dein BWM auch die Bewegung erkennt. Wenn du da still oder zu still bist, geht das Licht aus.

Beim Fibaro und Aeotec sieht man per LED die erkannte Bewegung.

Ja, Fibaro Motion Sensor.
Ich habe die Zeit auf 10 Sekunden eingestellt, nach 51 Sekunden war das Licht aus, obwohl ich mich vor dem BWM bewegt habe. Es kann nur sein, dass du zwischen zwei Bewegungen ein paar Sekunden Wartezeit verstreichen lässt. Ich habe das mal im Tagebuch überprüft:
16:36:52 Bewegung erkannt
16:36:52 Licht auf 100 %
16:37:43 Licht auf 0 %
16:37:59 Keine Bewegung erkannt

Wie gesagt - funktioniert nur, wenn zwischen den Bewegungen Pausen sind, damit der BWM eine neue Bewegung erkennt. Für den Fitnesraum ist diese Einstellung nicht zu empfehlen :slight_smile:

Dei Idee hinter meiner Lösung war: LED-Stripes unter dem Bett. Wenn man das Zimmer betritt gehen diese an, ebenso wenn man nachts aufsteht.
Man kann sie aber zusätzlich als Stimmungslicht einschalten, wenn man beispielsweise im Bett liest.

Versuche es mit der Einstellung von @Wildsparrow. Das sollte für das Schlafzimmer funktionieren. Nur bei Morgengymnastik wirst du nach 45 Sekunden im Dunkeln stehen.

Vielen Dank für die freundlichen Antworten auf meine Frage. Ich werde schauen, welcher der Ansätze am besten für mich passt. Und auch vielen Dank für die Erklärung der Suchfunktion! :wink::slight_smile:

Bei mir hat es nicht geklappt.
Hat gnadenlos nach 30 Sekunden abgeschaltet, und blieb dann auch ne Weile aus.

Wenn ich nun eine Verzögerung wegen der nächtlichen Bewegungen im Bett einbauen möchte, dann sehe ich da so:

  • mehr als 4 Sekunden Verzögerung bringt nichts.
  • nach der Verzögerung (“beim Ausführen der Aktion”) kann ich ja nochmals prüfen lassen
  • das geht aber nur wenn das Dauerpräsenzsignal kleiner ist
  • also muss ich das im Gerät (Geräteeinstellungen) auf 4 Sekunden stellen.
    Jetzt kann ich ein stellen: Wenn Gerät Bewegung bewegung meldet, dann nach 4 Sekunden “Aktion ausführen und dabei nochmals prüfen”, also heißt dass, das der Bewegungsmelder nochmals abgefragt wird - und nun hoffentlich keine Bewegung mehr meldet.

Jetzt müsste doch das Ziel erreicht sein, richtig?
Mit anderen Worten eine Bewegungsempfindlichkeit von 3 Sekunden.

Grüße
klauswerner

Ja, das ist das Problem, was ich ansprach, wenn du eine Dauerbewegung hast. In diesem Fall empfehle ich dir 2 HGs zu erstellen:

HG 1:
Wenn Bewegung
Dann Licht einschalten
Und HG 2 stoppen
HG 2:
Wenn keine Bewegung
Dann Licht nach (Bewegungsalarm + Totzeit) ausschalten.

Erkennt der BWM noch Bewegung, bleibt das Licht an und wird erst nach der angegebenen Zeit ausgeschaltet, wenn auch wirklich keine Bewegung mehr erkennt wird.

Der Fibaro hat eine “Totzeit” hat. Das ist eine Zeitspanne nach Ende des Bewegungsalarms, in der er keine neue Bewegung erkennt. Deshalb sollte die Zeit auf einige Sekunden einstellt sein. Ich habe Dauer Bewegungsalarm + 21 Sekunden. Also: Beim Fibaro in der Küche habe ich 2 Minuten Bewegungsalarm eingestellt. Dann stellt er das Licht nach 2 Minuten + 21 Sekunden aus. Dadurch bleibt das Licht mindestens 4 Minuten, 21 Sekunden an. In der Küche ist das OK, in anderen Räumen kannst du den Bewegungsalarm entsprechend kürzer oder länger einstellen, wie du es brauchst. -

Denke daran, dass eine kurze Bewegungsalarm-Zeit auch entsprechend öfter meldet, der Batterieverbrauch also höher sein wird.

Wieso macht ihr es eigentlich so kompliziert?!
Gerade der Fibaro MS hat optimale Einstellmöglichkeiten.
Mit der richtigen Kombi aus Blindzeit und Abschaltverzögerung braucht es doch nur 2 einfache HG‘s

HG1
Wenn Bewegung an
Dann Licht an

HG2
Wenn Bewegung aus
Dann Licht aus

Die richtige Einstellung der Parameter 3 und 4 ( PIR-Sensor Impulszähler und PIR-Sensor Erfassungszeitraum) lässt sich auch die zusätzlich die Empfindlichkeit einstellen.

Und zu guter letzt könnt ihr euch die Abfrage der Helligkeit in HG‘s mit der richtigen Einstellung (Parameter 8 & 9) auch sparen.

Ich habe überall wo der FMS eine Z-Wave Aktor bei Bewegung bei Unterschreitung einer bestimmten Helligkeit schaltetet Assoziationen im Einsatz. Ohne das das auch nur ein Flow(HG) dazwischen funkt. Und es funktioniert tadellos ohne das ich im Dunklen stehen muss. :grinning:

1 Like

Vielleicht muss ich dann wohl wechseln :slight_smile: Ich habe den Hue. MAcht ja eigentlich was er soll, aber man kann die Empfindlichkeit nicht via homee beeinflußen.
Und so löst er bei der kleinsten Bewegung im Schlafzimmer aus.
Ich habe auch schon überlegt die untere Häfte des Sensos mit Alu-Folie abzukleben.
So das er Bewegung erst ab einer bestimmten Höhe wahrnimmt.
Ob das was bringt?