2.40.0 Batteriezustand wird nur beim Restart abgefragt/geloggt

Nachdem in der letzten Version schon aufgefallen ist, das der aktuelle Batterieladezustand wohl ein Problem hat:
In der releasten Version 2.40.0 werden von allen Geräten nur die Batteriezustände beim Reboot abgefragt/geloggt.
Selbst wenn ich das Log exportiere, sind nur Daten vorhanden, welche den letzten Restart darstellen:
Beispiel (Heute wurde kurz nach 19:00 ein Restart über die Webapp initiiert:
Dana-Lock
2023-09-08 09:24:40,69
2023-09-25 19:11:00,68

Spirit Thermostat:
2023-09-07 20:23:22,85 ( Der Restart vom 08 ist hier gar nicht aufgeführt)
2023-09-25 19:11:25,60

Devolo Raumthermostat (Wohnzimmer)=> OK
2023-09-18 16:01:28,98
2023-09-19 16:01:30,97
2023-09-20 04:01:49,98
2023-09-20 10:01:48,97
2023-09-20 22:01:48,98
2023-09-21 04:01:49,97
2023-09-23 16:01:53,98
2023-09-23 22:01:52,97

Devolo Raumthermostat (Badezimmer) => NOT OK
Seit dem 4.9 keine Daten mehr vorhanden:
2023-09-01 03:13:59,86
2023-09-01 09:13:59,87
2023-09-02 15:13:57,86
2023-09-02 21:13:57,87
2023-09-03 21:13:55,86
2023-09-04 03:13:54,87
2023-09-04 21:13:55,86

Quad Wall Mate:
2023-09-07 20:56:47,89
2023-09-08 19:00:58,88
2023-09-13 13:08:27,86

Überflutungssensor:
2023-07-23 22:22:48,86
2023-08-11 23:47:55,85


Bis auf das eine Devolo Raumthermostat schaut es bei allen anderen Batteriebetrieben Geräte schlecht aus. Es sind keinerlei Logeinträge in den exportierten Files zwischen den Reboots vorhanden und werden entsprechend auch nicht angezeigt.

Jetzt kann es ja sein, das gleiche Werte nicht in die DB übernommen werden. Jedoch erklärt dies nicht, warum die 87% fehlen und direkt nach einem Reboot (Soft) plötzlich dann die 86% erscheinen (Als Beispiel Wall-Mate)
2023-09-08 19:00:58,88
2023-09-13 13:08:27,86

1 „Gefällt mir“

Liegt es eventuell daran:

Oder:

Da wurde halt viel optimiert, kann das bei dir der Fall sein?

1 „Gefällt mir“

Wenn das bedeutet, das keine Daten mehr aufgenommen werden: Ja…, das ist jetzt aber sakastisch gemeint … Check doch einfach mal deine Batterie betriebene Geräte ( am besten über den Export) und zeig, das es bei dir besser läuft…

Ich glaube, ich verstehe dein Problem nicht:

Core Version: 2.40.0 (f5f56878)
Web App Version: 2.40.1 (bed4033b) | beta

Guten Morgen @Dirk1,

werden von allen Geräten nur die Batteriezustände beim Reboot abgefragt/geloggt

So weit ich es einschätzen kann, ist dein „Devolo Raumthermostat (Wohnzimmer)“ auch ein Batterie Gerät, was dann „alle“ nicht mehr betreffen könnte und was mir eher auffällt, warum bei diesem die Werte nach oben gehen oder sehe ich die Daten falsch?

Mal ganz grob gesagt, werden die Werte nur noch aufegenommen die sich verändern und die überhaupt vom Gerät ankommen und gesendet werden, was bei einem neustart „Wakeup“ natürlich bei den meisten der Fall sein sollte.

Wenn Werte sich ändern und erst nach dem Reboot erscheinen, kann es mit dem WakeUp verhalten des Gerätes zu tun haben.

Aber gerne würde ich es mir bei dir zur Sicherheit mal ansehen, was welches Gerät bei dir genau sendet, kannst du mir bitte einen Supportzugang per PN zukommen lassen?

1 „Gefällt mir“

@Steffen

Auch heute wieder aufgefallen
Version 2.40.1
Die ganze Zeit stand der Batterielevel vom Spirit Heizkörperthermostat auf 35%.
Nach einem Restart vom Brain Cube ist der Level auf 25% runter und es kam eine Batteriewarnung.
Batterien getauscht (Gerät natürlich Stromlos und extra langsam getauscht), Batteriewarnung war verschunden (OK), aber der Level blieb trotzdem bei 25% obwohl das Thermostat ja komplett neu gestartet werden musste (Weil eben die Batterien weg und durch Neue ersetzt wurden) Erst nach einem erneuter Restart vom Cube würde der Batterielevel aktualisiert.

Nach dem Batteriewechsel (Level 25%)

Die fallenden Kurve liegt an der noch etwas suboptimalen Darstellung vom Diagramm

Nach dem Neustart vom Cube

3 „Gefällt mir“

@Steffen

Um das Thema mal nicht im Sande verlaufen zu lassen:
Gestern Abend habe ich dem homee mal einen Restart gegönnt:

  • Aeotec WallMote Quad => Seit einer Ewigkeit angezeigten Batterielevel von 51% nach dem Restart auf 38% aktualisiert
  • Spirit Arbeitszimmer => Seit einer Ewigkeit angezeigten Batterielevel von 100% nach dem Restart auf 85% aktualisiert
  • Spirit Wohnzimmer => Seit einer Ewigkeit angezeigten Batterielevel von 40% nach dem Restart auf 30% aktualisiert
  • Spirit Schlafzimmer => Seit einer Ewigkeit angezeigten Batterielevel von 45% nach dem Restart auf 30% aktualisiert
  • Spirit Schlafzimmer => Seit einer Ewigkeit angezeigten Batterielevel von 50% nach dem Restart auf 40% aktualisiert

Ohne Reboot würden mir die alten Werte bis zum Sankt Nimmerleins Tag als aktuelle Werte präsentiert :frowning:

3 „Gefällt mir“

Kann und habe ich auch schon bestätigt…interessiert aber leider scheinbar niemanden bei homee… :man_shrugging:

Deine Hartnäckigkeit finde ich aber gut! :+1:

Ich hatte/habe auch noch Themen, aber bin es leid da noch Zeit zu investieren.

VG
Andi :cowboy_hat_face:

3 „Gefällt mir“

Guten Morgen @Dirk1,

könntest du den Zeitraum von „einer Ewigkeit“ nochmal genauer definieren?

Ist es bei allen Geräten bei dir so oder nur bei bestimmten?

Der letzte Reboot (von mir initiiert) war Anfang Mai. Das war dann auch das letzte Mal, das sich die Werte geändert haben.
Es sind folgende Geräte bei mir:
Alle Spirits Eurotronics Heizthermostate, der Aeotec Wallmote Quad und das Danalock V3.
Bei den Danfoss (Devolo) Raumthermostaten scheint es zu funktionieren, zumindest ändern sich die Werte mal zwischendurch. Die Wassersensoren FGFS101 kann ich nicht beurteilen, da die Batterie sich bisher (im Beobachtungszeitraum) gar nicht geändert hat.

Gestern hat der Brain-Cube beim Durchblättern einer Jahresansicht ein „Bäuerchen“ gemacht…
Was soll ich sagen? Nach dem unfreiwilligen Restart kamen auch schon gleich 2 Batterie Warnungen (Wohn- und Schlafzimmer Thermostat Batterie schwach) . Beide Thermostate hatten bis zum Restart noch fröhliche 30% angezeigt.

@Steffen
Jetzt haben wir 2 Device hier, wo ich die Batterien wechseln kann und das (leider) zu erwartende Ergebnis ist, das nach dem Batterie-Wechsel zwar der Batterie Alarm von homee weggenommen, jedoch der Batterielevel beim alten Wert stehen bleibt und nicht (bis zum nächsten Restart) akualisiert wird.
Ich werde erst einmal deine Antwort abwarten bevor ich die Batterien tausche. (Zumindest einige Tage)

1 „Gefällt mir“