Community

Anwesenheitserkennung mit homeean presence


#204

Das Update lässt sich mit sudo npm update -g homeean-presence --unsafe-perm oder mit
sudo npm install -g homeean-presence@latest --unsafe-perm installieren.


#205

Da war der Stefan schneller - siehe vorige Antwort. :wink:
Anschliessend (oder vorher) kannst du die voherige Änderung an dem Service wieder rückgängig machen (Environment-Variable wieder löschen). Nach einem Neustart des Services wird dann wieder geloggt, aber eben deutlich weniger. Das tut der SD card gut, und dem Platzverbrauch auch.

Hier das logging von 2 Tagen (statt vorher 35.000 Zeilen):. :wink:

2019-4-25 06:56:19 [INFO]  homeean-presence: nobody @home, triggering webhook for absence
2019-4-25 07:30:59 [INFO]  homeean-presence: somebody @home, triggering webhook for presence
2019-4-25 14:37:32 [INFO]  homeean-presence: nobody @home, triggering webhook for absence
2019-4-25 14:39:22 [INFO]  homeean-presence: somebody @home, triggering webhook for presence
2019-4-26 07:08:29 [INFO]  homeean-presence: nobody @home, triggering webhook for absence
2019-4-26 07:35:09 [INFO]  homeean-presence: somebody @home, triggering webhook for presence
2019-4-26 14:05:12 [INFO]  homeean-presence: nobody @home, triggering webhook for absence
2019-4-26 14:18:32 [INFO]  homeean-presence: somebody @home, triggering webhook for presence

cheers,
spoocs


#206

@spoocs und @stfnhmplr Besten Dank. Habe das Update nun auch gemacht. Ich werde mal die Log Datei beobachten :slight_smile:


#207

Hey spoocs

darf ich fragen wie Du den Fehler mit dem ble scan error gelöst hast? Hab exakt das gleich nach einem update :frowning: Manuell scannen geht…

Danke und Gruss
Uwe

EDIT: Hat sich erledigt. Nachdem ich homeean-presence nochmal mit
sudo npm install -g homeean-presence --unsafe-perm installiert habe, läuft wieder alles so wie es soll :slight_smile:


#208

@stfnhmplr ist es möglich pro Person 2 unterschiedliche webhooks für anwesend bzw. Abwesend abzusetzen? Beziehungsweise kann man 2 webhooks irgendwie in der config mit und hinter absent einfügen. Der Hintergrund ist der, ich teste gerade ein anderes System und möchte dort auch die Anwesenheit der einzelnen Personen mit webhooks abbilden. Ich bin mit der Erkennung von Homeean presence extrem zufrieden.
Ich hatte schon ein zweites absent und präsent bei den Personen mit den entsprechenden webhooks hinterlegt, das funktioniert dann aber nicht. Dann habe ich die Personen doppelt angelegt geht auch nicht da ich nach der gleichen ip oder mac Adresse filtere.
Vielen Dank


#209

@stfnhmplr - wenn Du das machst, dann ggf. auch die Möglichkeit schaffen beliebige curl-Aufrufe absetzen zu können um homeean-presence auch mit Zentralen benutzen zu können die JSON verstehen… Das würde völlig neue Zielgruppen für homeean-presence eröffnen…


#210

Wenn es nur ums testen geht, könntest du als workaround von homee aus den Webhook zum anderen System ausführen (“weiterreichen”). Ist nicht ganz Sinn der Sache, ich weiss, aber zumindest kriegst du so den presence-Status erstmal testweise via homee aufs Zielgerät.

cheers,
spoocs


#211

Das wird wahrscheinlich meine Übergangslösung :grin:


#212

Das geht aktuell nicht. Könnte man einbauen, allerdings überzeugt mich das aufgrund von existierenden Alternativen momentan noch nicht :wink:
Den Webhook könnte man auch an Node-RED schicken und von dort an zwei oder mehr Endpunkte weiterleiten. Dort könnte man dann auch curl Befehle und beliebige andere Befehle ausführen.


#213

Hi,
ich bin grad dabei presence zum Laufen zu bekommen, doch leider noch recht erfolglos :disappointed_relieved:

Ich bekomme immer den Fehler mit dem angeblich belegten Port:
Error: listen EADDRINUSE :::3000

Es handelt sich um ein komplett neu installiertes Raspbian-stretch und es ist nur homeean-presence via homeean-Installer installiert.

Versucht hab ich bis jetzt:

  • Port ändern (hab diverse getestet)
  • mehrmals den Pi neu gestartet
  • Pi neu installiert

Ansonsten hier noch meine config (aber denke nicht das es an der liegt)

{
"interval": 30,
"threshold": 300,
"port": 3000,
"persons": [
    {
        "name": "Daniel",
        "ip": "192.168.75.50",
        "webhooks": {
            "absent": "http://192.168.75.59:7681/api/v2/webhook_trigger?webhooks_key=MEINKEY&event=Daniel-geht",
            "present": "http://192.168.75.59:7681/api/v2/webhook_trigger?webhooks_key=MEINKEY&event=Daniel-kommt"
        }
    }
]

}

Hoffe ihr könnt mir weiterhelfen :slight_smile:


#214

Muss leider 2 Posts machen, als Neuling darf man ja nur 1 Bild pro Post machen ^^

Wie ihr in den Bildern sehen könnt muss der Port von homeean-presence belegt sein, denn wenn ich homeean-presence stoppe ist der Port frei:


#215

Bei der Installation über homeean brauchst du homeean presence nicht selber starten. Es wird automatisch über ein Systemscript gestartet. Daher ist auch der Port belegt. Quasi also ein Autostart.

Den aktuellen Status siehst du mit sudo systemctl status homeean-presence
Wenn du status durch restart ersetzt, startest du den Dienst neu. Hier kann es manchmal passieren, dass der Port noch belegt ist. Dann hilft ein Neustart des Pi’s. Alternativ kannst du noch start, stopoder disable einsetzen. Letzteres deaktiviert den Autostart, Start und Stop sind selbsterklärend.


#216

Hi,
ja das ist mir soweit auch alles klar.
Ich versuche den Dienst ja nicht selbst zu starten.

Sprich nach einem Pi-Neustart bekomme ich die Fehlermeldung wenn ich den Debug starte


#217

Hi,

vorab: geile Sache! Lass Dir nen Kaffee schmecken!

ICh habe zwei iPhones mit deren WLAN-MAC- und IP-Adressen registriert und den Threshold auf 500 gesetzt aufgrund der Tips hier (vorher war da zu nervös und hat dauernd gemeldet). Eben war ich mit dem Hund raus, nach den ca. 500sec löste der Webshook “frank abwesend” aus und ich bekam zum Test ne Push. Top!
Auf dem Rückweg, ca. 100m vor dem Haus und noch ohne WLAN-Verbindung, krieg ich ne Push “frank anwesend”. ??? eben das homeean-presence.log gezogen und angeschaut, seit gestern abend um halb 8 keine Einträge mehr.
Was mache ich falsch? Was habe ich übersehen?

Nachtrag: Status meldet:
“Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.”

Gruß
Frankie


#218

Das widerspricht sich ein wenig :wink: Mit dem DEBUG Befehl startest du doch eine zweite Instanz von homeean presence… Das DEBUG vor dem eigentlichen Befehl ist nur die Umgebungsvariable damit der Log aussagekräftiger ist. Darauf folgt der Startbefehl für homeean presence. Du musst vorher den Dienst stoppen wenn du dir auf diese Weise die Ausgabe anschauen möchtest.

Dein Vorgehen: Pi Neustart - homeean presence Autostart - DEBUG Befehl (startet auch homeean presence) - Port belegt durch die Autostart Version.

Mögliches Vorgehen: Autostart deaktivieren (... disable ...) - Pi Neustart - DEBUG Befehl

Alternatives Vorgehen:

Anstelle von LOG_LEVEL=NONE schreibst du dann LOG_LEVEL=DEBUG
Anschließend findest du die DEBUG Informationen im Logfile, Pfad am Ende des obigen Zitats.


#219

achso, ja ok das erklärt es natürlich.

Ich dachte durch den Aufruf des DEBUG sehe ich was grad so abgeht


#220

Vielen Dank, das werde ich machen :grinning:

Mit dem letzten Update wurden die Logeinträge als Standard drastisch reduziert. Es wird jetzt nur noch ausgegeben, wenn sich der Status des Haushalts ändert oder irgendwelche (schwerwiegenden) Fehler auftreten. War eventuell in der Zeit deiner Abwesenheit noch jemand Zuhause? Dann ändert sich der Status des Haushalts nicht und so gibt es keinen Eintrag.

Wenn du eine detailliertere Ausgabe haben möchtest, musst du den Service abändern. Siehe mein Beitrag von vor ein paar Minuten mit der Anleitung von @spoocs.

Wenn vorher die Abwesenheit erkannt wurde, muss homeean presence das iPhone eigentlich irgendwie gefunden haben. Hast du an deinem Standort in die Wlan Einstellungen geguckt, oder nur auf das Symbol oben rechts im Homescreen geachtet? Letzteres kommt etwas zeitverzögert, ggf. hat sich das iPhone schon vorher am AP angemeldet. Wenn dann genau die Abfrage durch homeean presence läuft, ist es durchaus möglich, dass es ganz früh erkannt wird.


#221

ok jetzt funktioniert es :+1:
Danke für die Hilfe

Dachte durch den Debug sieht man direkt in der Konsole was er macht (so wie auf dem Screenshot hier: Anwesenheitserkennung mit homeean presence)


#222

Direkt in der Konsole könntest du es dir als quasi „Echtzeit-log“ mit
tail -f <logfile> ansehen. Falls es das ist, was du meinst.

cheers,
spoocs


#223

Hallo Stephan,

Meine Frau war noch da, das würde das log erklären. Ich war später nochmal alleine weg, da hat er dann anwesend erst vor der Haustür gemeldet. Eigentlich dürfte er mich da nicht im wlan gesehen haben, das sind noch 5 bebaute Grundstücke dazwischen. Ich hab nur im homescreen geschaut.
Ich beobachte das noch mal weiter, bevor ich das scharf schalte.

Gruß Frankie